Firefox with Adobe SVG plugin will crash when leaving an SVG-containing page

RESOLVED DUPLICATE of bug 306220

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 306220
13 years ago
13 years ago

People

(Reporter: VK, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Firefox with Adove SVG plugin will crash if you try to leave a page with embeded
SVG content. 

Reproducible: Always

Steps to Reproduce:
1. Download and install latest (3.03 now) Adobe SVG plugin from
<http://www.adobe.com/svg/viewer/install/>

2. Copy file NPSVG3.dll from "C:\Program Files\Common Files\Adobe\SVG Viewer to
"C:\Program Files\Mozilla Firefox\plugins" ("Mozilla Firefox" is your Firefox
installation folder, so it may differ).
Firefox will still not see the plugin (via about:config etc.), but at least it
will start use this plugin. (??????????)

3. Go to <http://www.adobe.com/svg/viewer/install/svgtest.html> Enjoy the
animation for a while and try to leave the page.
You can use any other SVG for it, even static ones like
<http://www.carto.net/papers/svg/samples/#base>

Actual Results:  
Firefox crashes miserably.

Expected Results:  
Firefox should keep working

First of all there must be something wrong with your plugin detection mechanics,
and "open/closed intefaces" is not an excuse. Adobe makes this plugin for all
browsers for three major OS, but only Firefox fails to detect it. It's getting
kinda an army humor: "the whole platoon missed the leg, only our sergeant is
keeping left-left-left" ;-)

If Adobe SVG is "closed interface" and overall bad guy, then put your own SVG as
downloadable plugin ASAP. Just clean it up for now from all animation and
zooming functions. Leave just static shape drawing and filling - I understand
that it's already much stable.
<maps.google.com> is the first big sign of what's coming, and Mozilla is risking
to miss the train.
(Reporter)

Comment 1

13 years ago
Just finished reading the *last year* discussion on the bug # 133567

Again: Firefox crashes only when you are *leaving* the page with embedded SVG.
You can stay on such page as long as you want. You can open another window and
browse where you want. This explains all these "it works! - oh, no it doesn't!"
in the thread (I mean the bug # 133567).

Updated

13 years ago
Summary: Firefox with Adove SVG plugin will crashe when you are leaving an SVG-containing page → Firefox with Adove SVG plugin will crash when you are leaving an SVG-containing page
have you tried http://www.adobe.com/svg/viewer/install/beta.html
svg-3 was never made for mozilla/Firefox svg-6 beta was
Summary: Firefox with Adove SVG plugin will crash when you are leaving an SVG-containing page → Firefox with Adobe SVG plugin will crash when you are leaving an SVG-containing page
Please provide a Talkback ID from that crash
(Reporter)

Comment 4

13 years ago
I guess Talkback is not included in the default installation of Firefox 1.0.4.
At least I clicked nothing but OK's during my installation, and it's not here.
If I find out how to add it w/o reinstall, I'll provide the error track. 

So far I can confirm that the error occurs only when leaving a page with SVG
embed or when closing the relevant browser window. So it's a clear case of
memory cleanup failure(?).

C# debugger shows:

AppName: firefox.exe	 AppVer: 1.0.4.0	 ModName: npsvg3.dll
ModVer: 3.0.0.94	 Offset: 000047bb

Unhandled exception at 0x530047BB in firefox.exe: 0xC0000005: Access violation
reading location 0x00000038.
...
530047BB  call        dword ptr [eax+38h] 
...
Summary: Firefox with Adobe SVG plugin will crash when you are leaving an SVG-containing page → Firefox with Adobe SVG plugin will crash when leaving an SVG-containing page
(Reporter)

Comment 5

13 years ago
Just installed SVG Viewer 6.0 Beta from
<http://www.adobe.com/svg/viewer/install/beta.html>

1) Plugin installation bug is still the same.
You still need to manually copy NPSVG6.dll from <C:\Program Files\Common
Files\Adobe\SVG Viewer 6.0> to <C:\Program Files\Mozilla Firefox\plugins>
Firefox still doesn't see the plugin in its settings, but at least is able to
use it.

2) The test sites from OP displayed OK, browser doesn't crash on leaving/closing.

3) Firefox fails to switch SVG layers visibility though (try on
<http://www.carto.net/papers/svg/samples/#base>), IE does it fine. But in
comparison of crash it's just a negligeable detail :-)

4) What does it have to do with the problem anyway? 
Do you really think I should forward Firefox users to the beta plugin page which
contains the text "This page links to pre-release versions of Adobe SVG Viewer.
These downloads are provided primarily for developers. blah-blah..."
Would *you* download 2 megs of such stuff?
Firefox 1.1 will include native SVG support,

you can download a recent nightly build from 
<http://www.mozilla.org/releases/nightly.html>

Comment 7

13 years ago
reporter: the firefox installer will randomly decide (favoring not) to install
talkback, if you want talkback, specify it in the installer.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 10

13 years ago
I have a different behaviour of Firefox with SVG viewer. In 1.0.7 worked fine,
with beta it just shows some numbers, instead of charts.
It's on http://www.tomattrick.org. I will post some pictures when I'll have my
website back online

Comment 11

13 years ago

*** This bug has been marked as a duplicate of 306220 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.