incorrect layering of flash modules

RESOLVED DUPLICATE of bug 137189

Status

()

--
major
RESOLVED DUPLICATE of bug 137189
13 years ago
13 years ago

People

(Reporter: great_snoopy, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050524 Firefox/1.0 (Ubuntu package 1.0.2 MFSA2005-44)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050524 Firefox/1.0 (Ubuntu package 1.0.2 MFSA2005-44)

Please take a look at the provided test URL;
Two flash items are involved in this :
- The big slideshow-like flash on the center of the screen
- The small blue menu above.
When the mouse is above the blue menu, the correspondent submenu should open
ABOVE the big slideshow flash. Instead the submenus are opening behind the
slideshow. This does not seem to be a flash plugin issue, but rather a browser
issue regarding "z-sorting", as someone told me.
This only happens on linux. That menu works fine on firefox/win32.
It seems that sometimes the flash sections get place above any other elements,
which is not right. Let's take a look at another site :
http://www.spiruharet.ro/
The brown menu above (which is javascript this time) gets covered by the small
logo at the bottom-left of the page, which is flash based.

Reproducible: Always

Steps to Reproduce:
1.go to one www.autoitalia.ro or www.spiruharet.ro
2.Put the mouse over the menubar
3.See how the submenu's are covered by flash areas even if they should not. 
This happens even with flash or javascript submenus.

Actual Results:  
Incorrect z-sorting of certain elements.

Expected Results:  
The visual elements should be correctly sorted and displayed in the correct
order so that a previously loaded (an static) element does not cover newly
displayed items.

I am not very sure that this is only a mozilla firefox only problem and
has nothing to do with the flash plugin itself. However, the mozilla
developers are better suited to identify the problem behind this abnormal
rendering. If this proves to be a flash issue, then we should notify
macromedia.
I will mark this bug as "Major" as I think that correct rendering of 
a page is a major issue. Feel free to change it back to "normal" if I am wrong.
(Reporter)

Comment 1

13 years ago
... the flash plugin version is 7.0.25
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
I have the same problem on many sites.
Go to:
http://www.gigabyte.com.tw/
move mose on Products button, Products menu is covered by background flash
animation.

Also go to:
http://www.skoda-auto.pl/
try to move mouse on "Salon" 2 entry from 10!

I'm using
Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
and Flash 7.0 r25

AFAIR this bug (in Mozilla and Firefox, not this bug in Bugzilla) is at least 2
years old, and should be fixed as fast as possible (of course if this isn't
caused by bugy Flash plugin), because it's verrrrry annoying.

As Great Snoopy mentioned under Windows and with the same Flash plugin version,
menus works ok.

Please reply quickly!

Comment 4

13 years ago
Please reopen if you disagree

*** This bug has been marked as a duplicate of 137189 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.