smooth scrolling continues long after mouse button released

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Stewart, Assigned: roc)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050420
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050420

When smooth scrolling is on, scrolling does not always stop when the mouse
button is released after pressing and holding (shortly) on either the Up or Down
arrow on the scroll bar.

Reproducible: Always

Steps to Reproduce:
1. Go to the given web page ( http://www.komw.net/partyline/thisweek/ )
2. Click and hold on the down arrow on the scroll bar for a short period of time.
3. Release the mouse button and observe.

Actual Results:  
The page continues scrolling.  The scrolling will often continue for a full page
of the display (on a window of about 800x600 pixels).

Expected Results:  
The scrolling should have stopped when I released the mouse button.  I wouldn't
expect the page to continue scrolling for more than one or two lines.

Happens with all themes here -- Pinball, Classic, and Modern.

Comment 1

13 years ago
worksforme with linux trunk 2005060905 and 1.7.8

can you try a more recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/

==> layout

Comment 2

13 years ago
layout!
Assignee: guifeatures → roc
Component: XP Apps: GUI Features → Layout: View Rendering
Product: Mozilla Application Suite → Core
QA Contact: ian
Version: unspecified → 1.7 Branch
I can't reproduce either.
(Reporter)

Comment 4

13 years ago
Have you tried at the site given?

http://www.komw.net/partyline/thisweek/

In 1.7.10, it still keeps scrolling on its own.  It seems to be more likely to
do this with multiple columns/frames?  (It didn't do it for me, either, on this
Bugzilla page, though it does it fairly consistently on the KOMW page noted.)
sandreas: 1.7.whatever is NOT a trunk build. It's old stuff.
(Reporter)

Comment 6

13 years ago
Oops, sorry.
...
Hmmm, looks very different from 1.7.x.  Trying to install a 1.7.x chrome on it
(Pinball 2004-09-15_1.7 in my case, oops) causes a segmentation fault; I think
that an error message would be better. :)

As to this problem, though...
The build retrieved today from
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
does correct the problem. While it does not immediately stop when releasing the
mouse button, neither is it continuing for several (like 8) seconds, like 1.7.10
does.

Since it only continues maybe 1 to 3 lines now, I suppose it's acceptable.  The
scrolling is also jerkier (less smooth) than 1.7.10 appeared to be, though.

Comment 7

12 years ago
(In reply to comment #6)
> As to this problem, though...
> The build retrieved today from
> http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
> does correct the problem. While it does not immediately stop when releasing the
> mouse button, neither is it continuing for several (like 8) seconds, like 1.7.10 does.
> 
> Since it only continues maybe 1 to 3 lines now, I suppose it's acceptable.  The
> scrolling is also jerkier (less smooth) than 1.7.10 appeared to be, though.

Sandreas, how is it now with http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/

closable as WFM? 
(Reporter)

Comment 8

12 years ago
Looks like KOMW's page changed, and it no longer causes this problem under 1.7.x, so there seems to be no point in checking this any more.  (Then again, X has been upgraded in the interrim as well, so maybe that did it...)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.