OnChange for <select> sometimes doesn't fire when using combination of mouse and keyboard navigation

RESOLVED WORKSFORME

Status

Core Graveyard
Java APIs for DOM
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Timwi, Assigned: Ashu Kulkarni)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

159 bytes, text/html
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

See Steps to Reproduce.

Reproducible: Sometimes

Steps to Reproduce:
1. Find (or create) a page with a <select> drop-down which has JavaScript
attached to the OnChange event.
2. Click the drop-down with the mouse.
3. Use the Home or End keys to change the selected item in the drop-down.
4. Click the drop-down with the mouse again (NOT the item in the list)
5. Click somewhere on the webpage to move focus away from the mouse
Actual Results:  
Sometimes (not always), nothing happens

Expected Results:  
OnChange should always fire when the selected item changes

Comment 1

13 years ago
If you would attach a testcase allowing us to duplicate the problem it would
speed up the process of getting this confirmed a lot. 
(Reporter)

Comment 2

13 years ago
Created attachment 186047 [details]
Test case

Geez. How hard can it be to make an HTML file with a <select> with an onChange
in it?

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
This bug is not a duplicate of bug 126379.

Bug 126379 is about when onChange should or should not fire, but this bug is
that in some cases onChange doesn't fire *at all* (even when the element loses
focus).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4)
Gecko/20050807 Firefox/1.0+.

Please reopen if you still see this bug in Deer Park Alpha 2 or later, and when
your final selection in the dropdown is different from the item that was
initially selected or selected the last time onChange fired.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.