{ib} [4.xP]Graphic in wrong location

VERIFIED WORKSFORME

Status

()

P3
critical
VERIFIED WORKSFORME
20 years ago
19 years ago

People

(Reporter: jeffu, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
http://www.filez.com The Visual Studio icon displays in the wrong place (center
left).  In 4.51 and IE the graphic displays in the upper right corner.

<TABLE WIDTH="270" BORDER="0" CELLSPACING="0" CELLPADDING="0">
    <TR><TD>
        <A
HREF="http://spinbox1.filez.com/?RC=38&AI=230&RL=http://msdn.microsoft.com/vstud
io/headlines/ad/vsfilez.htm">
        <IMG SRC="http://www.mp3.com/spin_html/visualstudiologo.gif" WIDTH=88
HEIGHT=40 BORDER=0 ALIGN="RIGHT" ALT="Visual Studio">
        </A><FONT FACE="Arial,Helvetica" SIZE="2">
        <P>NEW VISUA....

This has not yet been check on Unix or Mac

Updated

20 years ago
QA Contact: 4110

Updated

20 years ago
Assignee: troy → kipp

Comment 1

20 years ago
Interesting. Because the floated image is inside of a A element, we're not
moving the floater out of the flow. That part should get fixed when you move
your floater logic into the frame construction code

The table isn't necessary in reproducing the bug. Just this will do:
<A HREF="http://msdn.microsoft.com/vstudio/">
<IMG SRC="http://www.mp3.com/spin_html/visualstudiologo.gif" WIDTH=88
HEIGHT=40 BORDER=0 ALIGN="RIGHT" ALT="Visual Studio">
</A><FONT FACE="Arial,Helvetica" SIZE="2">
<P>NEW VISUA....
(Reporter)

Updated

20 years ago
OS: Windows NT → All
Hardware: PC → All
(Reporter)

Comment 2

20 years ago
I have verified that the problem exists on all platforms (which isn't a
surprise based on Troys comments).

Comment 3

20 years ago
*** Bug 3072 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
*** Bug 2646 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Summary: [PP]Graphic in wrong location → [4.xP]Graphic in wrong location

Updated

20 years ago
Target Milestone: M6

Updated

20 years ago
QA Contact: 4110 → 1698

Updated

20 years ago
Summary: [4.xP]Graphic in wrong location → {ib} [4.xP]Graphic in wrong location

Updated

20 years ago
Severity: normal → critical
Priority: P2 → P3

Comment 5

20 years ago
It now demonstrates a block-in-inline bug...
Whiteboard: WORKSFORME?
Target Milestone: M15
I cannot see anything wrong with the minimized test cases any more.

I suggest this bug be marked WORKSFORME, unless anyone can see a reason not to.
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
Whiteboard: WORKSFORME?
The remaining bug on the filez page is an alignment bug that I will file
separately. (align=center is translated to text-align:center, and so contained
blocks are not being centered.)

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 8

20 years ago
Verified WORKSFORME; I can't reproduce any of the problems, either --- on any
platform using --- using the simplified test cases referenced by this bug on
5.25.99 M6 candidate [Mac OS/Win32] or 5.26.99 Linux.
You need to log in before you can comment on or make changes to this bug.