Toggle "Page Style" to "No Style" and back to standard breaks display: table CSS property

RESOLVED FIXED in mozilla1.9.2

Status

()

RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: gtdev, Assigned: bzbarsky)

Tracking

({testcase})

Trunk
mozilla1.9.2
x86
All
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

The example HTML code displays a page with a single table row generated from div
elements that are set to the proper CSS "display" values to form a table. When
switching the "Page Style" via the View->Page Style menu to "No Style" and then
back to standard, the divs are displayed as regular block elements with
seemingly all properties but "display" shown as intended.

Reproducible: Always

Steps to Reproduce:
1. Load test page "table-testcase.xhtml"
2. Set Page Style to "No Style" in the View menu
3. Set Page Style back to Standard

Actual Results:  
Block elements are shown as:
#menu
#content
#stats

Expected Results:  
Block elements should be shown as:
#menu#content#stats
(Reporter)

Comment 1

13 years ago
Created attachment 186027 [details]
Testcase that shows the effect described in the original description

Comment 2

13 years ago
v. on Windows i686 FF 1.0.4. Asking anyone with editbugs reading this message to
confirm and add 'testcase' to the keywords.

Comment 3

13 years ago
Seing this as well with trunk build 20050611 on xp
Component: General → Layout
Keywords: testcase
OS: Linux → All
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk

Comment 4

10 years ago
This error still persists with FF 3.0.1 on Mac OS X 10.4.11 .  Also, here is an example of a webpage which exhibits the opposite behavior:  the page renders incorrectly on first viewing, but toggling from "page style" to "no style" and back to "page style" causes it to render correctly.

http://www.uscms.org/

Comment 5

9 years ago
The borders shouldn't disappear in the first place
http://al.howardknight.net/msgid.cgi?STYPE=msgid&MSGI=<878wkfa52n.fsf@jidanni.org>
and rest of thread...
Works for me,
Mozilla/5.0 (Windows; U; Windows NT 6.1; zh-TW; rv:1.9.2) Gecko/20100105 Firefox/3.6

Don't know if this bug has fixed, I'll try to reproduce this on Ubuntu later.
(Reporter)

Comment 7

9 years ago
It's at least still broken in 3.5.6:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.6 (like Firefox/3.5.6; Debian-3.5.6-1)

It'd be nice to see a bug fixed in under 5 years for once.
This was fixed back in March 2009 by the patches in bug 148810.  So yeah, comfortably under 5 years.  ;)
Assignee: nobody → bzbarsky
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Depends on: 148810
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2
You need to log in before you can comment on or make changes to this bug.