Irregular crashes when closing tab/windows or quiting Camino with bfcache enabled [@ nsChildView::GetParent() + 0x24]

RESOLVED FIXED in Camino0.9

Status

P1
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: torben, Assigned: bryner)

Tracking

({crash})

unspecified
Camino0.9
PowerPC
Mac OS X
crash
Dependency tree / graph

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
Camino 2005061108 (v0.9a)

With bfcache enabled (browser.sessionhistory.max_viewers, 5) Camino will
sometimes crash when I close a tab/window or quit Camino. No crash with bfcache
turned off. Just before the crash Camino will hang for some seconds (with the
nice spinning bathball).
(Reporter)

Comment 1

13 years ago
Created attachment 186029 [details]
Crash Log

Updated

13 years ago
Keywords: crash
Summary: Irregular crashes when closing tab/windows or quiting Camino with bfcache enabled (nsChildView::GetParent() + 0x24) → Irregular crashes when closing tab/windows or quiting Camino with bfcache enabled [@ nsChildView::GetParent() + 0x24]
(Reporter)

Comment 2

13 years ago
Created attachment 187349 [details] [diff] [review]
needs work

This seems to have been fixed  with the checkin from bug 293173.

However, I had just found another solution, attaching it here in case this
problem should resurface.
(Reporter)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 293173
Resolution: --- → FIXED
Attachment #187349 - Attachment description: patch that isn't need anymore → patch that isn't needed anymore
(Reporter)

Comment 3

13 years ago
Looks like I spoke too soon, I just had a crash with the latest nightly (TB7122092Q), reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

13 years ago
Attachment #187349 - Attachment description: patch that isn't needed anymore → patch under testing

Comment 4

13 years ago
Related to bug 227489, perhaps?
(Reporter)

Comment 5

13 years ago
Comment on attachment 187349 [details] [diff] [review]
needs work

Camino just crashed with this patch, back to the drawing table :-(
However, it seems like Camino now only crashes when closing windows or quiting,
not when closing tabs.
Attachment #187349 - Attachment description: patch under testing → needs work

Comment 6

13 years ago
*** Bug 299872 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: nobody → bryner
Status: REOPENED → NEW
(In reply to comment #5)
> However, it seems like Camino now only crashes when closing windows or quiting,
> not when closing tabs.
> 

Is that bug 299872?
bryner was trying to look at this last night, but the talkback reports don't
have stacks with them and he said he can't repro this himself. i wonder what's
going on with the server.
Flags: blocking1.8b3?

Updated

13 years ago
Component: History: Session → Page Layout
Flags: blocking1.8b3?
Product: Core → Camino
Target Milestone: --- → Camino0.9
Version: Trunk → unspecified

Updated

13 years ago
Priority: -- → P1
(In reply to comment #9)
> bryner was trying to look at this last night, but the talkback reports don't
> have stacks with them and he said he can't repro this himself. i wonder what's
> going on with the server.

Some of my TB IDs (not related to this bug) are 7271777, 7042521, 6774484,
6791182, and 6796134; I'm sure when I searched for the older ones of them on
talkback-public shortly after they were submitted they had useful stacks.  Even
the newest/most complete one in the list, 7271777, doesn't list functions and
line numbers and that sort of thing.  I don't see any recent bugs in Talkback
Client or Talkback Server....

(In reply to comment #10)
> I don't see any recent bugs in Talkback Client or Talkback Server....

Maybe it's this mis-named bug, bug 297719?  Sorry for the off-topic noise.

Comment 12

13 years ago
K I just had this crash, and have seen it happen a couple of times last couple
of weeks. I just submitted a talckback report TB7306347G and my crash log looks
the same as the one alreaddy attached.
(Assignee)

Comment 13

13 years ago
Created attachment 188633 [details] [diff] [review]
patch

I was able to reproduce something like this just going back and forward through
some pages on pcworld.com.  It appears that what happens is the child widget
outlives its parent, and has a dangling pointer.  My suggestion is that we do
what the carbon code does for this, and null out the parent pointer on all of
the children when the parent goes away.
Attachment #188633 - Flags: superreview?(pinkerton)
Attachment #188633 - Flags: review?(joshmoz)

Comment 14

13 years ago
Comment on attachment 188633 [details] [diff] [review]
patch

applies, builds, runs, no more crashes, looks good
Attachment #188633 - Flags: review?(joshmoz) → review+
Comment on attachment 188633 [details] [diff] [review]
patch

looks good to me except for the tabs, can you clean those up before checking
in? sr=pink.

simon, you concur?
Attachment #188633 - Flags: superreview?(pinkerton) → superreview+

Comment 16

13 years ago
Yup, looks good (other than the tabs/spaces).
(Assignee)

Comment 17

13 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsChildView::GetParent() + 0x24]
You need to log in before you can comment on or make changes to this bug.