Closed Bug 297556 Opened 15 years ago Closed 15 years ago

mozilla crashes trying to open the web page www.banesto.es [@ ActionList::PushAction]

Categories

(Core :: Plug-ins, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: annonygmouse, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.8) Gecko/20050513 Debian/1.7.8-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.8) Gecko/20050513 Debian/1.7.8-1

Just try to go to http://www.banesto.es (spanish bank). It crashes unmercilly.


Reproducible: Always

Steps to Reproduce:
1. go to URL: http://www.banesto.es
2. wait untill it finishes loading
3. Admire the crash.

Actual Results:  
Mozilla crashed.

Expected Results:  
Show the web page.

Maybe not related, but I tried firefox on W98 and it showed a message saying
something like "the macromedia plugin has made an invalid operation, you should
reboot the browser".

I just installed firefox and it renders the web correctly.
(firefox -> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050610
Firefox/1.0.4 (Debian package 1.0.4-3)
Under the URL
http://sebastia.homelinux.net/~jo/bugs/mozilla/
there are two files
pete_mozilla.txt
pete_mozilla_new_profile.txt

with the result of running:
strace mozilla http://www.banesto.es &> pete_mozilla.txt
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/2005061307
I've asked some people and it seems that works for people
with a gecko version bigger than Gecko/20050517
for example: Gecko/20050610

Do I close the bug and try a newer version?
Attached file stacktrace
looks INVALID
==> plugins for now
Assignee: general → nobody
Component: General → Plug-ins
Keywords: crash
Product: Mozilla Application Suite → Core
QA Contact: general → plugins
Summary: mozilla crashes trying to open the web page www.banesto.es → mozilla crashes trying to open the web page www.banesto.es [@ ActionList::PushAction]
Version: unspecified → Trunk
resolving INVALID -- this is a flash bug
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
*** Bug 297519 has been marked as a duplicate of this bug. ***
This means that is OK if mozilla crashes because of a flash bug? Shouldn't
Mozilla be more robust?

Sebastià.
we're accepting patches. we try not to crash when flash crashes on windows.
write a good patch for linux and we'll see about accepting it. in the interim,
please inform us about the vendor/version of your plugin and the ticket number
of your report to your vendor about this crash in *their* code.
(In reply to comment #10)
> we're accepting patches. we try not to crash when flash crashes on windows.
> write a good patch for linux and we'll see about accepting it. in the interim,
> please inform us about the vendor/version of your plugin and the ticket number
> of your report to your vendor about this crash in *their* code.

I already reported that concrete bug with banesto.es website to Adobe/Macromedia but I didn't get any answer from them, neither a ticket number, so I guess they don't care (the fact that Windows has Flash 8.x but Linux is still with 7.x is a good sign of how they ignore us).

I understand that is not your fault, but would be really good if someone with the needed experience (I'm not talking directly about you, just asking for anyone even from outside your team) would try to get a patch to prevent this kind of crashes.

Thank you.
well, this isn't the place to "ask" for things. there are already bugs about such things somewhere, and actually, I thought this specfic stack was in some other bug.

if you want to spend resources, organize people with money to sponsor a developer to work on out of process plugins.

maybe someday adobe will improve flash by using the same out of process stuff that the reader plugin uses (or maybe they could provide a generic wrapper for any plugin to use...)
Crash Signature: [@ ActionList::PushAction]
You need to log in before you can comment on or make changes to this bug.