Closed Bug 297558 Opened 19 years ago Closed 18 years ago

no support for nested xlink:href and @target

Categories

(Core :: SVG, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 110817

People

(Reporter: nexum, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050610 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050610 Firefox/1.0+

as I'm currently developing a SVG-application - I had to experience that it's
neither possible to use nested xlinks (give a hole group one behaviour and
change for some elements within this group this behaviour) nor to use a target.

Feel free to concider following code:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11-flat-20030114.dtd">
<svg xmlns="http://www.w3.org/2000/svg" width="100%" height="100%"
xmlns:xlink="http://www.w3.org/1999/xlink">
	<style type="text/css">
	<![CDATA[
		.st0{fill:#808DFF;pointer-events:fill}
		.st1{fill:#FF3737;pointer-events:fill}
		.st2{fill:#01AD4E;pointer-events:fill}
		.st3{fill:#A9775D;pointer-events:fill}
		.stx{fill:#BCF83D;pointer-events:fill}
	]]>
	</style>
	
	<g id="church">
		<a xlink:href="http://www.kircheallgemein.de" target="_blank">
			<g id="surface">
				<a xlink:href="http://www.kirchespeziell.de">
					<polyline id="surface01_1_" class="stx" points="670.2,336.6 637.1,343.9
641,369.3 674.5,361.5 " />
				</a>
				<polyline id="surface02_1_" class="st2" points="654.9,415.2 654.2,447.7
695.3,447.5 695.1,418.4 688.9,415.2 " />
			</g>
		</a>
	</g>
</svg>

Reproducible: Always

Steps to Reproduce:
save the code above as .svg and load in FF 1.0+
Actual Results:  
1. only the parent-link works (www.kircheallgemein.de)
2. @target on anchor does not work

Expected Results:  
1. there should be 2 links (www.kircheallgemein.de & www.kirchespeziell.de)
2. www.kircheallgemein.de should open as a new document
3. tried to change the structure of the document - no result
Where in the SVG spec does it say that you can do this? Note that SVG doesn't
re-use XLink, it just co-opts XLink's attributes for its own purposes.
(In reply to comment #1)
ok, so please let me ask.

on http://www.w3.org/TR/SVG11/linking.html it says:
A simple link is defined for each separate rendered element contained within the
'a' element; thus, if the 'a' element contains three 'circle' elements, a link
is created for each circle. For each rendered element within an 'a' element, the
given rendered element is the local resource (the source anchor for the link).

wouldn't it then be logical that a nested xlink can change the behaviour of a
selected element?

Also I'd like to refer to
http://www.w3.org/TR/SVG11/linking.html#AElementTargetAttribute and
http://www.w3.org/TR/SVG11/attindex.html concerning the target attribute.

I think the discussion from Norman Walsh
http://lists.w3.org/Archives/Public/public-xml-core-wg/2005Apr/0047.html
describes better then I'd be able to formulate the topic.

If I'm completely wrong, please let me know about my misunderstanding.
Depends on: 127903
The nesting part of this bug is a dup of bug 110817.
And the target bit was fixed in bug 300868. Marking this as a dup of bug 110817 for the remaining nested links bit.

*** This bug has been marked as a duplicate of 110817 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
No longer depends on: 127903
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.