problems with a <tree> element in XUL popup [@ nsView::GetDimensions]

RESOLVED WORKSFORME

Status

()

Core
XUL
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Andreas Herz, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

1.20 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Crash if I try to open a <tree> element in a popup 
e.g. context menu of click on a button.


Reproducible: Always

Steps to Reproduce:
1. open example document
2. click on button 
3. ...crash

Actual Results:  
crash

Expected Results:  
Open a working XUL <tree>

The current trunk build doesn't crash but the <tree> doesn't 
receive any mouse (click) events.
(Reporter)

Comment 1

13 years ago
Created attachment 186127 [details]
Test document.

Attention: 
  crash if you click on the button....
  With version 1.0.4 on Suse 6.2
(Reporter)

Comment 2

13 years ago
in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050517 Firefox/1.0+
the tree is shown.....BUT the click "offset" isn't corrent

to select an element in the tree you must click two of three elements below
(if I click on the 5th the 2nd. will be receive the event).

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050618
Firefox/1.0+ ID:2005061809

WFM. Have you tested this on the latest trunk build?
(Reporter)

Comment 4

13 years ago
tested with the latest-trunk.

behaviour:
 tree control is visible but I must click one or two rows below
 to select any element in the tree of the test document.

 I think the offset of the treecontrol is alway '0' and not
 the current possition in the document.


 
(Reporter)

Comment 5

13 years ago
Error exists in "Deer Park Alpha 2" too

Comment 6

12 years ago
So it doesn't crash anymore?
Component: General → XP Toolkit/Widgets: XUL
Product: Firefox → Core
QA Contact: general → xptoolkit.xul
Summary: Crash if an <tree> element in XUL popup → problems with a <tree> element in XUL popup
Version: unspecified → 1.8 Branch

Comment 7

12 years ago
Incident ID: 10714669
Stack Signature	nsView::GetDimensions a038d188
Product ID	Firefox10
Build ID	2005091517
Trigger Time	2005-10-15 22:17:48.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (001e329f)
URL visited	
User Comments	
Since Last Crash	24 sec
Total Uptime	655 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/view/src/nsView.h,
line 248
Stack Trace 	
nsView::GetDimensions 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/view/src/nsView.h,
line 248]
nsView::GetClippedRect 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp,
line 839]
nsViewManager::UpdateView 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp,
line 1761]
nsViewManager::MoveViewTo 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp,
line 2603]
nsContainerFrame::PositionFrameView 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 510]
nsContainerFrame::PositionChildViews 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 1020]
nsSprocketLayout::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsSprocketLayout.cpp,
line 517]
nsContainerBox::DoLayout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::DoLayout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::DoLayout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::DoLayout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::DoLayout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsRootBoxFrame::Reflow 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsRootBoxFrame.cpp,
line 240]
nsContainerFrame::ReflowChild 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
IncrementalReflow::Dispatch 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 904]
PresShell::ProcessReflowCommands 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6401]
ReflowEvent::HandleEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6226]
PL_HandleEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/threads/plevent.c,
line 674]
0x778b0c24
nsMathMLChar::Stretch 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/mathml/base/src/nsMathMLChar.cpp,
line 1611]
0x26eb8007

*** This bug has been marked as a duplicate of 35299 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Keywords: crash
Summary: problems with a <tree> element in XUL popup → problems with a <tree> element in XUL popup [@ nsView::GetDimensions]
(Reporter)

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

12 years ago
"Test document"  now doesn't crash the firefox BUT

Please - try to select any tree element in the popup!!!!

You must click 2 or 3 rows below to select any element. The ofset seems to
be wrong.
Severity: critical → blocker

Comment 9

12 years ago
(In reply to comment #8)
> "Test document"  now doesn't crash the firefox BUT
> 
> Please - try to select any tree element in the popup!!!!
> 
> You must click 2 or 3 rows below to select any element. The ofset seems to
> be wrong.
> 

The selection problem sounds like a separate bug than the crash this bug originally reported.  The problem is hard to see in the testcase on this bug.

I filed bug 319062 with a title, description, and testcase specific to the select problem after running into it independently.  
Depends on: 319062

Comment 10

12 years ago
Since there's been a new bug filed and this one doesn't crash anymore, resolving as WFM.
Severity: blocker → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsView::GetDimensions]
You need to log in before you can comment on or make changes to this bug.