PassAlong.com - sniffs for "Firefox", rejects non-Firefox Gecko browsers

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
4 years ago

People

(Reporter: rderuiter, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Attempting to enter www.passalong.com gets one redirected to
http://www.passalong.com/Music/browser.htm and displays message " The website
you are trying to access can only be viewed using Internet Explorer Version 5.5
or above" (with a link to download IE). No other navigation is possible with FF.

Reproducible: Always

Steps to Reproduce:
1. Enter www.passalong.com in the Firefox navigate bar
2.
3.

Actual Results:  
Navigation begins but redirects to http://www.passalong.com/Music/browser.htm,
with the message displayed above (in "Details"). No other navigation on the site
is permitted, not even by manually inserting a site URL (by copy/paste) as seen
in IE.

Expected Results:  
I would expect to be able to navigate the site as in IE.
(The problem is with the site, not with FF, as far as I can tell.)

N/A (I did a search to see if this has been reported before and couldn't find
anything. Sorry if I'm repeating a known problem.)

Comment 1

11 years ago
It's been redesigned somewhat so that Firefox works now, but other browsers get redirected to

http://www.passalong.com/Music/browser.aspx

Confirming.
Blocks: 334967
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: PassAlong.com does not allow browsers other than IE 5.5 or above → PassAlong.com - sniffs for "Firefox", rejects non-Firefox Gecko browsers
Duplicate of this bug: 297918
Site doesn't exist, we get a parked domain. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.