If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

setting style.display to inline-block from a javascript function has no effect

RESOLVED DUPLICATE of bug 9458

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 9458
12 years ago
12 years ago

People

(Reporter: bbp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When setting style.display for an element to inline-block from a javascript
function, nothing happens, however setting style.display to none or block yields
the desired effect. However, inline-block seems to be perfectly handled when set
in static HTML.

Reproducible: Always

Steps to Reproduce:
1. go to http://people.via.ecp.fr/~bbp/mozilla-bug.html
2. in the bar list, select inline-block
3. in the bar list, select block

Actual Results:  
bar appears only after step 3

Expected Results:  
bar should have appeared after step 2

I have the same problem on a debian (sarge) provided version of firefox. I
checked this works as expected in IE, and I got quite a bit of fun:
"inline-block" works in IE, but not "none", this page must definitely be hard to
render :)

I could not find any workaround that works in both browsers.
inline-block is not a valid display type:
http://www.w3.org/TR/CSS21/visuren.html#propdef-display

Invalid?

*** This bug has been marked as a duplicate of 9458 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.