Closed Bug 298799 Opened 19 years ago Closed 19 years ago

[Mac] Browser tab titles move and flicker when changing tabs

Categories

(Firefox :: Tabbed Browser, defect, P2)

PowerPC
macOS
defect

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: waynegwoods, Assigned: asaf)

Details

Attachments

(1 file)

Since tab reordering was enabled in early June (bug 179656), text in the tab bar
moves and flickers when changing tabs. This doesn't only affect the titles of
tabs being switched from/to, it also affects distal ones.

Reproducing is as simple as opening several empty tabs and switching between
them. The "(Untitled)" text in other tabs flickers, or moves slightly. In builds
from 20050605 and earlier, the text appeared rock solid.

Apologies if this is a dupe or known issue, but I haven't seen it mentioned
specifically.

I'm also making an assumption that this is linked to tab reordering. I've
confirmed that the bug didn't exist in 20050605 and does exist in 20050608, but
I haven't yet been able to test the two builds in between.
That's actually a regression from my tab-focusring bug.
Assignee: mconnor → bugs.mano
Priority: -- → P2
Target Milestone: --- → Firefox1.1
Status: NEW → ASSIGNED
Attachment #187335 - Flags: review?(mconnor)
Attachment #187335 - Flags: approval-aviary1.1a2?
Looks like I guessed wrong. Glad you're onto it. Thanks :)
Attachment #187335 - Flags: review?(mconnor) → review+
Attachment #187335 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
Checking in browser.css;
/cvsroot/mozilla/toolkit/themes/pinstripe/global/browser.css,v  <--  browser.css
new revision: 1.7; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Looks much better. Thanks :)
Hi Asaf... did the fix for this bug cause bug 328193, or perhaps it revealed an underlying problem? The focus ring thing started just as this bug was fixed, but I only just got around to reporting it ;)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: