UI: Acct Settings & Mail Folder not displaying same # of accounts

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: nbaca, Assigned: alecf)

Tracking

({polish})

Trunk
Future
All
Windows NT
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] [nsbeta3-])

(Reporter)

Description

19 years ago
Build 2000-03-01-08M15: NT4, Linux 6.0, Mac 8.5.1

Overview: Create two mail accounts, exactly the same (using the same names, 
servers etc...). It creates the accounts but the mail folder will show two 
accounts and Account Settings will only show one.

Steps to reproduce:
1. Create a mail account (i.e. qatest20)
2. Create another mail account using the same account information (i.e. 
qatest20)

Actual Results:
- After the second account is created, notice that Account Settings displays two 
sets of the account.
- Close Account Settings and the Folder pane also shows 2 seperate accounts,both 
displaying as qatest20.
- Open Account Settings again and now there is only one mail account displayed.

Expected Results: 
- I would expect Account Settings to display the same number of accounts as the 
mail folder pane. 
- Why would someone want two seperate accounts displaying in the folder pane 
when it's actually one account? Shouldn't we discourage this and let the user 
know what they are doing? I'm not sure what the ultimate expected behavior 
should be.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → nbaca
(Assignee)

Comment 1

19 years ago
I will prevent this from happening while you're in the wizard.
Status: NEW → ASSIGNED
Target Milestone: M17
(Reporter)

Updated

19 years ago
Summary: Acct Settings & Mail Folder not displaying same # of accounts → UI: Acct Settings & Mail Folder not displaying same # of accounts

Comment 2

19 years ago
Mail Review recommends this bug as beta2 stopper.  Adding nsbeta2 keyword.
Keywords: nsbeta2
(Assignee)

Comment 3

19 years ago
I'd like to dispute this being a beta2 stopper, I don't think a user is likely 
to do this.
(Assignee)

Updated

19 years ago
Target Milestone: M17 → M18
(Reporter)

Comment 4

19 years ago
I agree, this is unlikely.

Comment 5

19 years ago
During our discussion, it was mentioned that AOL users were likely to hit this
due to the way we're handling their names.  If we fixed that, maybe this
wouldn't matter at all.  Kevin's point was that we need to not look stupid by
allowing such inconsistencies to show through the UI.  I don't feel strongly
about it, but Kevin should say something.

Comment 6

19 years ago
Yup, my position is that if an AOL account has multiple screen names, that the 
user won't have any idea if they can check mail in those two separate screen 
names on that single account. Unless I'm missing something. The reason I think 
this is a bit more likely, is that I *know* AOL users like to manage multiple 
screen names, and would prefer to change identities on the fly without signing 
off. This feature working properly will likely promote the use of NSCP Mail with 
AOL users more. Anyone disagree?
(Assignee)

Comment 7

19 years ago
Wait, I totally disagree with steve, I'd like to hear where the basis for this
claim was - the bit about "due to the way we're handling the names" - I don't
see how AOL users are more likely to hit this.

Comment 8

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]

Comment 9

19 years ago
Just back from sabbatical, so I'm not totally sure what I meant :-)

I think the problem was one of migrating an existing email account and then 
creating another of the same name during activation.  At this moment, I can't 
think of what else it might have been.  Are we preventing this case?

Adding Bhuvan to the CC to get the activation slant on this.

Nominating for beta3 on the assumption we have to do something...
Keywords: nsbeta3, polish
(Reporter)

Comment 10

19 years ago
I have an AOL account with 2 screen names (nsbaca and nsbaca2). I was able to 
create an account for each screen name so they appear as seperate accounts in 
one profile (even though they are both called "AOL account"). For this reason I 
don't think this bug will effect AOL users. 

There is a seperate problem where if you have 2 AOL accounts, the second account 
can't send messages. This occurs even when the 2 AOL accounts are unrelated. 
I'll log a seperate bug on this last issue.

Updated

19 years ago
Summary: UI: Acct Settings & Mail Folder not displaying same # of accounts → UI: Acct Settings & Mail Folder not displaying sa
Whiteboard: [nsbeta2-] → [nsbeta2-] [nsbeta3-]
Target Milestone: M18 → Future
(Assignee)

Comment 11

19 years ago
repairing the title
Summary: UI: Acct Settings & Mail Folder not displaying sa → UI: Acct Settings & Mail Folder not displaying same # of accounts
(Reporter)

Comment 12

18 years ago
Trunk Build 2000-09-25-09M18: NT4
Branch Build 2000-09-26-09M18: NT4, Linux 6.0, Mac 9.04

- Adding 2 AOL accounts with the exactly the same information allows 
progression through the Account Wizard. It results in one AOL account appearing 
in Account Manager and the Folder pane.

- Adding 2 IMAP accounts (or 2 POP accounts) with the exactly the same 
information is no longer allowed because the Account Wizard displays a message 
stating that the user needs to change either the Username or the Server Name 
before progressing.

- Using an older profile which had a variety of accounts that had been 
manipulated (added/deleted/set as default) over time, I was able to create
two accounts with the same account information but I can't reproduce.

Since the most common scenario is working I would suggest marking this
as Worksforme or Fixed.

Comment 13

18 years ago
WFM based on Ninoschka's comments
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

18 years ago
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.