Status bar continues to display "Transferring data from server..." after transfer has finished.

RESOLVED DUPLICATE of bug 209330

Status

()

RESOLVED DUPLICATE of bug 209330
14 years ago
14 years ago

People

(Reporter: nigelw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

This is happening when I am adding a script element to the document using

var s = document.createElement("script");
s.src = "http://url.of.servlet.which.generates.script";
document.getElementsByTagName("head")[0].appendChild(s);

This is a technique I use to update the document without reloading the page. It
loads select elements and populates selection lists etc.

Nothing can ever change the status bar again until the page goes through a reload.

I have enabled status bar changing by the way.

Reproducible: Always

Steps to Reproduce:
Put a script like this in a document:

var s = document.createElement("script");
s.src = "http://url.of.servlet.which.generates.script.or.a.hardcoded.js.file";
document.getElementsByTagName("head")[0].appendChild(s);
Actual Results:  
The script will run, but the status bar is "stuck".

Expected Results:  
The status bar should revert to its previous value.

*** This bug has been marked as a duplicate of 209330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.