Unable to build Firefox on with GCC 4.0.0 (5026), after bug 236300 and 299235

VERIFIED DUPLICATE of bug 299305

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 299305
13 years ago
13 years ago

People

(Reporter: krmathis@gmail.com, Assigned: Mark Mentovai)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050629 Firefox/1.0+ (PowerBook)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050629 Firefox/1.0+ (PowerBook)

Earlier today my build process failed with an error in nsSafariProfileMigrator.o
That problem is now fixed in bug 236300

But I now get a new error a bit further down the build process:


Reproducible: Always

*** This bug has been marked as a duplicate of 299235 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Sorry, I somehow hit "Commit"before I finished.

Here are the error:
----------------------------------
oderFinish used from dynamic library ../../dist/bin/libnss3.dylib(secasn1e.o)
not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearTakeFromBuf used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearTakeFromBuf used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearStreaming used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearStreaming used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearNotifyProc used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1EncoderClearNotifyProc used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1Encode used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _SEC_ASN1Encode used from dynamic library
../../dist/bin/libnss3.dylib(secasn1e.o) not from earlier dynamic library
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(secasn1e.o)
symbol _libVersionPoint used from dynamic library
../../dist/bin/libplc4.dylib(plvrsion.o) not from earlier dynamic library
@executable_path/libplds4.dylib(plvrsion.o)
collect2: ld returned 1 exit status
make[4]: *** [firefox-bin] Error 1
make[3]: *** [libs] Error 2
make[2]: *** [tier_99] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
------------------------------------

Reproducible: Always

Steps to Reproduce:
1.Grab source
2.Build with GCC 4.0.0 (5026)

Actual Results:  
Build errors out

Expected Results:  
Build continue its process.

Im using the following .mozconfig:
http://homepage.mac.com/krmathis/Trunk/mozconfig.txt
(Reporter)

Comment 3

13 years ago
Sorry, but I did not get to post the error message before you marked this one as
a duplicate to 299235
I dont think its the same bug, so I want this reopened. :)
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 4

13 years ago
Kai, that's not an error.  I need to see the entire output, starting with the
line that begins "c++ -o firefox-bin"

Mark
Assignee: nobody → mark

Comment 5

13 years ago
When I try to build firefox - adding by hand the patch for bug 299235 - firefox
kills itself while creating firefox-bin file.

To be simple, it dies in the end of the building process.
(Assignee)

Comment 6

13 years ago
Right.  I need to see the errors from the build log, starting with the line that
begins c++ -o firefox-bin.
(Reporter)

Comment 7

13 years ago
Created attachment 187913 [details]
build log

Here you have the looong build log.
(Assignee)

Comment 8

13 years ago
This is what I expected.

*** This bug has been marked as a duplicate of 299305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.