Keyboard focus restored to last selected link when user uses back button

RESOLVED DUPLICATE of bug 36539

Status

()

defect
RESOLVED DUPLICATE of bug 36539
14 years ago
14 years ago

People

(Reporter: jongund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The bug results in inefficent keyboard navigation.  People continually need to
restart navigation from the beginning of a page after using the "back" or other
history navigation feature.  The last "link" selected on a page needs to be part
of the history information and the keyboard focus restored to that link when
some uses the history to return to a previous page.

One question is what should happen when a page that is in the history is
returned to by forward link navigation.  Should the last link selected be given
focus.

Reproducible: Always

Steps to Reproduce:
1. Tab to link somewhere in the middle of a page
2. Select the link to move to a new page
3. Use the "back" button to move to the previous page


Actual Results:  
Keyboard focus is moved to the link at the beginning of the page, rather than
continuing from the previous selected link location on the page.  The history of
where the last link selected seems to be lost.  This makes it difficult for
keyboard only users to "browse" the links on a page using the back button, since
everytime they press the back button the keyboard focus moves to the beginning
of the page.

Expected Results:  
The last link selected on the page should have focus so the user doesn't need to
repeat "tabbing" to get to the last link they select to move to the next link on
the page.  This is a waste of time if someone is browsing the links on a page
and trying to move sequentially through the links on a page.

Keyboard navigation is much different than using the mouse to select links. 
Being able to make the last link selected as part of the "history" of a page is
important for efficient keyboard navigation.

Comment 1

14 years ago
I am writing to confirm this bug, and to echo the author's astute observation,
"Keyboard navigation is much different than using the mouse to select links."
See my Keyboard FAQ for my thoughts on the subject of keyboard access to Windows:

http://www.cantoraccess.com/keyaccess/keyaccessfaq.htm

Also:

> One question is what should happen when a page that is in the history is
> returned to by forward link navigation.  Should the last link selected be 
> given focus.

Symmetry is good; going back and forth between two linked pages is a natural and
efficient way to explore a web page without a mouse. Keyboard input focus should
always land on the referring link when moving from page to page. This is
analogous to the way that keyboard input focus lands (or should land!)on a
destination anchor when following a source anchor on the same page.

Also:

Mozilla's incremental search that allows users to type their way to a link is
the best thing to happen to mouseless browsing in years. Thank you!

Comment 2

14 years ago
Duplicate of Core bug 36539?
This is fixed by the new fast back feature, and will be in Firefox 1.1.

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.