Java based animation doesn't scroll properly

RESOLVED DUPLICATE of bug 162134

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 162134
13 years ago
13 years ago

People

(Reporter: JongAm Park, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050704 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050704 Firefox/1.0+

When there is a Java applet, especially, animation by Java, screen refresh is a
problem.

Try loading the IBM's URL I provided, and try scrolling it.

Sometimes, animation is not moved along with scrolling, sometimes the web page
itself is not redrawn properly if you scroll it.

Even Java animation in other tabbed window is displayed on your current tab window.

Reproducible: Always

Steps to Reproduce:
1. Try loading the URL I provided
2. Try scrolling
3.

Actual Results:  
Please see Details

Expected Results:  
Normal display of web page
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050706 Firefox/1.0+.

THis could be a MacOS X only bug.
(Reporter)

Comment 2

13 years ago
Yes. I confirmed that the Windows version didn't have this problem.

Comment 3

13 years ago
(In reply to comment #0)
 
> Even Java animation in other tabbed window is displayed on your current tab 
> window.

That is bug 162134

Comment 4

13 years ago
I can reproduce that badly-scrolling plugin effect in the oldest builds that I
can get to run on Tiger (Firebird, August 2003). So I wonder if that symptom is
also an aspect of bug 162134, just like the better-known "drawing on other tabs"
effect that Stefan pointed out.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Java based animation and a Firefox browser → Java based animation doesn't scroll properly

Comment 5

13 years ago
On closer examination, the bad-scrolling aspect of this bug is definitely part
of bug 162134 as well. Go there and do a find for the word "scroll" to see some
references, especially with respect to certain tickers but also other instances.
For examples, see bug 162134 comment 31, bug 162134 comment 56, bug 162134
comment 210.

*** This bug has been marked as a duplicate of 162134 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.