collapsing border model table margins

VERIFIED FIXED in mozilla0.9.9

Status

()

P2
normal
VERIFIED FIXED
20 years ago
17 years ago

People

(Reporter: dbaron, Assigned: karnaze)

Tracking

({css2, testcase})

Trunk
mozilla0.9.9
x86
Windows 95
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(1 attachment, 2 obsolete attachments)

743 bytes, text/html
Details
Collapsing border model table margins aren't quite done correctly.  The outer
half of the border should be in the margin.  Thus the left edges of the first
and second tables in the above URL shouldn't line up.  See the diagram in
http://www.fas.harvard.edu/~dbaron/csstest/tborder1.html
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Updated

20 years ago
Target Milestone: M7
(Assignee)

Comment 3

20 years ago
Moving to M9.

Comment 4

20 years ago
Created attachment 831 [details]
test case for 3000
erin@imaginet.com : your testcase is actually a text description of another
bug.  It looks like you attached the wrong file.
(Assignee)

Updated

20 years ago
Summary: collapsing border model table margins → [CSS 2] collapsing border model table margins
(Assignee)

Comment 6

20 years ago
Adding [CSS 2] to summary.
Summary: [CSS 2] collapsing border model table margins → {css2} collapsing border model table margins
(Assignee)

Comment 7

19 years ago
mass move to m14.
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
(Assignee)

Comment 9

19 years ago
Moving to M16.
Target Milestone: M14 → M16

Updated

19 years ago
Summary: {css2} collapsing border model table margins → collapsing border model table margins
(Assignee)

Comment 10

19 years ago
Moving to M17.
Target Milestone: M16 → M17
(Assignee)

Comment 11

19 years ago

*** This bug has been marked as a duplicate of 41262 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 12

19 years ago
I should have made a dependency instead of a dup. 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

19 years ago
Depends on: 41262

Comment 13

19 years ago
Created attachment 11135 [details]
Another test case

Comment 14

19 years ago
I just attached a test case which demonstrates that 'margin-top' is not
handled properly. I guess the rework of the collapsing/margin code should
fix this problem as well.
(Assignee)

Updated

19 years ago
Keywords: testcase

Comment 15

18 years ago
Milestone 0.8 has been released. We should either resolve this bug or update its
milestone.

Updated

18 years ago
Target Milestone: M17 → ---
(Assignee)

Comment 16

18 years ago
Moving to m1.0
Target Milestone: --- → mozilla1.0

Comment 17

18 years ago
QA contact update
QA Contact: chrisd → amar

Updated

18 years ago
Whiteboard: 5/21: reporter contacted for additional information

Updated

18 years ago
Whiteboard: 5/21: reporter contacted for additional information

Comment 18

17 years ago
this looks fixed on my new build.
anthonyd
Whiteboard: [awd:tbl]
That's because our support for the collapsing border model was turned off (but
not removed, I don't think).
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.7
(Assignee)

Comment 20

17 years ago
collapsing border bugs moved to m098
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 21

17 years ago
->m099
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 22

17 years ago
I think in quirks mode, the outer half of the table border should not be in the 
table margin. This will be compatible with IE (hence the quirk) and will not 
result in clipped borders if a table margin is not big enough. I'm not sure 
why the spec is the way it is, but it seems like it is going to be a pain for 
authors to have to figure out how big to make a table margin. 
Other browsers don't implement the collapsing border model, so there's no reason
to deviate from the spec.  We should only have quirks when there are significant
numbers of web pages that depend on an incorrect behavior.  If you really think
the spec is wrong, you should raise the issue with the CSS working group and try
to get the spec changed.
(Assignee)

Comment 24

17 years ago
Well, before trying to get the spec changed, I would like to amend the criteria 
for quirks mode to include "if all or most browsers implement a particular item 
contrary to the spec and it seems natural (at least to the user agent 
developers) to do it that way".
(Assignee)

Comment 25

17 years ago
I forgot to add that IE and Opera both appear to implement the collapsing border 
model, although not very well.
(Assignee)

Comment 26

17 years ago
Created attachment 67802 [details]
test case
(Assignee)

Updated

17 years ago
Attachment #831 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #11135 - Attachment is obsolete: true
Marking nsbeta1+
Keywords: nsbeta1+
(Assignee)

Comment 28

17 years ago
Fixed by meta bug 41262.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → FIXED

Comment 29

17 years ago
 Works fine with the build 2002030403. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.