Closed Bug 300058 Opened 17 years ago Closed 17 years ago

Artifacts near bottom of scrollbars

Categories

(Core Graveyard :: Widget: Mac, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID
mozilla1.8beta4

People

(Reporter: uriber, Assigned: mark)

References

Details

(Keywords: regression)

Attachments

(1 file)

All scrollbars now have a one-pixel-tall horizontal line going through them, a
few millimeters above their bottom. Initially it is gray, but after moving the
scroller over it, it receives the color of the scroller.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b3) Gecko/20050707
Firefox/1.0+

Screenshot coming up.
Attached image screenshot
This screenshot shows the artifacts on some scrollbars that were moved and some
that weren't.
BTW, I'm using OS X 10.4.1.
I'm seeing it too. Seems to be new in the 20050707 build.
Severity: normal → major
Flags: blocking1.8b4?
Keywords: regression
Depends on: 298677
Whiteboard: [no l10n impact]
This was caused by the event handler-based drawing patch in bug 298677.
The fix for this is in the updated patch over in bug 298677.
Assignee: joshmoz → mark
Fix checked in with bug 298677.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: blocking1.8b4?
Whiteboard: [no l10n impact]
Target Milestone: --- → mozilla1.8beta4
This was actually an OS bug, present in 10.4.0 - 10.4.2.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Bug 311399 reintroduced the control event handler, so these artifacts will show up again for 10.4.0 - 10.4.2 users.  I'm re-resolving this bug as INVALID because it's an OS bug.  The artifacts aren't present in 10.3.9 or 10.4.3.
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.