Closed Bug 300138 Opened 15 years ago Closed 15 years ago

can't find param cookiedomain in Bugzilla/Config.pm at line 150

Categories

(Bugzilla :: Installation & Upgrading, defect, P1, blocker)

2.18.2
defect

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: cidrasm, Assigned: Wurblzap)

References

Details

(Whiteboard: [blocker will fix][does not affect 2.20rc1])

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: 2.18.2

Performed a new install of 2.18.2 and received this error.  This parameter didn't exist in defparams.pl or 
$datadir/params.  Added the parameter to $datadir/params and still got this error (the parameter works if 
you comment out the die line Config.pm).  Added the parameter defparams.pl and no longer get the error 
(after uncommenting out the die line in Config.pm).  For whatever reason, the $datadir/params file works, 
but the Params() function call doesn't seem to be able to check something that didn't exist in defparams.pl

Reproducible: Always

Steps to Reproduce:
1.  New stock installation of 2.18.2
2.  Add the cookiedomain parameter to $datadir/params
3.  Try to login

Actual Results:  
can't find param cookiedomain in Bugzilla/Config.pm at line 150

Expected Results:  
Logged the user in.
Severity: critical → blocker
Status: UNCONFIRMED → NEW
Depends on: 268146
Ever confirmed: true
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Whiteboard: [blocker will fix][does not affect 2.20rc1]
Target Milestone: --- → Bugzilla 2.18
Version: unspecified → 2.18.1
regression on 2.18.2 due to bug 268146. :(
Assignee: installation → wurblzap
Version: 2.18.1 → 2.18.2
Checking in Bugzilla/CGI.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/CGI.pm,v  <--  CGI.pm
new revision: 1.10.2.5; previous revision: 1.10.2.4
done


2.18.3 will be released in a few hours.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.