If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Height of Preferences window is not set in prefWindow.style{Mac,Unix}

RESOLVED DUPLICATE of bug 284713

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 284713
12 years ago
12 years ago

People

(Reporter: Ognyan Kulev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; bg; rv:1.8b3) Gecko/20050710 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; bg; rv:1.8b3) Gecko/20050710 Firefox/1.0+

mozilla/browser/locales/en-US/chrome/browser/preferences/preferences.dtd contains:

<!ENTITY  prefWindow.styleWin     "width: 42em; height: 36em;">
<!ENTITY  prefWindow.styleMac     "width: 47em;">
<!ENTITY  prefWindow.styleUnix    "width: 42em;">

The problem is that on Unix when you go to General tab, exit Preferences, enter
Preferences and go to Privacy, there is no enough height for the Privacy tab. 
If Preferences is left when Privacy tab is active, entering back to Preferences
shows all of Preferences.  So the solution is to have "height:..." in all
operating systems.  I don't if this is problem for en-US, but I'm forced to add
height in Bulgarian (bg) l10n.

Reproducible: Always

Steps to Reproduce:
1. In Linux, go to Preferences / General
2. Leave Preferences
3. Enter Preferences (it's in General tab)
4. Go to Privacy tab
5. (there is no enough height)

Actual Results:  
Height of Preferences depends on last visited tab.

Expected Results:  
Height of Preferences cover all tabs.

All this is in bg l10n but I think this is a general issue.
The UNIX problems are known, this is a duplicate.

As for Mac, the prefwindow dynamically resizes like a normal Mac prefwindow, so
specifying a fixed height is just plain wrong.
Whiteboard: DUPEME

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 284713 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.