When designMode is active, "text-decoration: none" is ignored for links

RESOLVED DUPLICATE of bug 590716

Status

()

defect
RESOLVED DUPLICATE of bug 590716
14 years ago
9 years ago

People

(Reporter: fredck, Unassigned)

Tracking

({testcase})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

In the following URL:
http://www.fredck.com/bugs/firefox/linkdecoration.html

The link decoration style set to "none" is ignored because the designMode is 
set to "on".

Reproducible: Always

Steps to Reproduce:
1. Open http://www.fredck.com/bugs/firefox/linkdecoration.html?NoEdit
2. Now open http://www.fredck.com/bugs/firefox/linkdecoration.html
Actual Results:  
In the first URL, the "text-decoration: none" style is working correctly. In 
the second one, "text-decoration: none" style is ignored.

Expected Results:  
Both pages should behave as the first one.

Attention: if you first open the link on step 2 and them that one in the step 
1, it will not work due to another bug that I'll report in another bug report.

Comment 1

14 years ago
http://www.fredck.com/bugs/firefox/linkdecoration.html?NoEdit
Looks unstyled to me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b3) Gecko/20050708 Firefox/1.0+

The 1.0.x releases is using code that is about a year old right now.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ has builds
with code that is up to date. If you are going to test with a current nightly I
suggest downloading a zip build and making a new profile for this test. Running
a current nightly and a 1.0.x build on the same profile can lead to issues.
http://www.mozilla.org/support/firefox/profile#new
(Reporter)

Comment 2

14 years ago
OK... I've also installed the current nightly and I can confirm that the 
related problem is still happening with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b3) Gecko/20050710 
Firefox/1.0+

The fact is that http://www.fredck.com/bugs/firefox/linkdecoration.html should 
show the link without the underline.

Thanks for the advice Kevin.

Comment 3

14 years ago
Setting !important on the rule causes it to function as you expected. I am not
sure if the default canvas style is intended to be processed after inline style
sheets.
See:
http://lxr.mozilla.org/seamonkey/source/editor/composer/src/res/EditorOverride.css#74
This stylesheet is added when designmode is activated.
See also bug 63528 and bug 57757.
Component: General → Editor
Product: Firefox → Core
Version: unspecified → Trunk
Actually, this is WFM in current trunk build.
Reporter, could you please verify by testing with the latest trunk build?
http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 6

14 years ago
From Comment #2: 
I've also installed the current nightly and I can confirm that the related 
problem is still happening with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b3) Gecko/20050710 
Firefox/1.0+

Comment 7

14 years ago
I'm seeing this with linux suite trunk 2005071102
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 8

14 years ago
*** Bug 238516 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
I don't think that Bug 238516 is a duplicate as this one is referring to the fact that styles are not carried into IFRAMEs when designMode is on. Bug 238516 is related purely to what happens within the editor frame itself and has to external CSS associated with it. I've expanded on this further in Bug 238516.
Assignee: nobody → mozeditor
QA Contact: general

Comment 10

12 years ago
The EditorOverride.css still contains the following code as Minefield 3.0a2pre:

a:visited, a:active {
  cursor: text;
  color : inherit;
}

Code is at least 3 years old in my knowledge.

Comment 11

12 years ago
I confirm that this issue still remains, in Firefox 2.0.0.3 and FCKeditor 2.4.1 - the link styles are not inherited, unlike in IE.
QA Contact: editor
Assignee: mozeditor → nobody

Comment 12

12 years ago
I can confirm this in FF 2.0.0.3

in addition to text-decoration, color is also ignored
so defining this in an iframe with designMode='On' does not have effects:
A {
	color: red;
}
(Reporter)

Comment 13

12 years ago
Thinks got worst here with Firefox 3 Beta 1. Now, it looks like "text-decoration: none" is always active with designMode. So, by default, links are coming with no color and no underline (just like plain text).

To fix it at FCKeditor, we are applying the styles with the following CSS definition, which is an ugly dirty hack:

a[href]
{
	color: -moz-hyperlinktext !important;
	text-decoration: -moz-anchor-decoration;
}

Comment 14

12 years ago
Perhaps this issue is related to a very old misbehaviour of FF. If I set "no underline" in the user preferences, then the link in the test case above is not underlined.

The problem is that, whenever designmode is set to on, the user preferences for link color and underlining take precedence over any stylesheet attached to the document. Even if the preference allows the page to apply its own color and decoration.

Updated

11 years ago
Blocks: 424615

Comment 15

9 years ago
Posted file Testcase

Updated

9 years ago
Keywords: testcase

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590716
You need to log in before you can comment on or make changes to this bug.