If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"layers" with a higher z-index block user from objects on "layers" with lower z-index

VERIFIED DUPLICATE of bug 12232

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 12232
18 years ago
17 years ago

People

(Reporter: Lance Hildebrand, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview Description:
     When viewing a page where you have mutliple "layers" (positioned blocks -
CSSP) and those "layers" have differing z-index's, the "layers" with a higher
z-index, when they cross over a "layer" with a lower z-index, will block objects
(ie. images, links, etc.) from the user, even when the "layer" is set to be hidden.
     When you change the higher (blocking) "layer's" z-index (ie. via
Javascript), to a z-index that is lower then the "layer" with the blocked
object, you can get at the object.

Steps to Reproduce:
1) View any page with multiple "layers" that have differing z-index's, with
ojbects on them, and those "layers" overlap.
2) Try to click on the object on a "layer", with a lower z-index, that is being
overlaped (overlaped over the object itself).  You will notice that you can see
the object, but can't do anything to it (no click, mouseover, etc.).

Actual Results:
     Object can not be dealt with in any way (other then just being able to look
at it).

Expected Results:
     You would be able to interact with the object as normal.

Build Date & Platform Bug Found:
     February 28, 2000 build on Windows 98

Additional Builds and Platforms Tested On:
     Doesn't occur on:
          Netscape Navigator 4.72 (Windows 98)
          Internet Explorer 4 or 5 (Windows 98)

Additional Information:
     Quick Code Snippet:
<html>
	<head>
		<style type="text/css">
			#layer1 { position: absolute; top: 0px; left: 0px; width: 300px; height:
100px; z-index: 1; visibility: visible;}
			#layer2 { position: absolute; top: 0px; left: 0px; width: 300px; height:
100px; z-index: 2; visibility: hidden;}
		</style>
	</head>
	<body>
		<div id="layer1">
			<a href="#">Test!</a>
		</div>
		<div id="layer2">
		</div>
	</body>
</html>

Updated

18 years ago
Component: All → Style System
Product: Architecture → Browser
QA Contact: shaver
Version: 5.0 → other

Comment 1

18 years ago
style bug?
Assignee: waterson → pierre
QA Contact: chrisd

Comment 2

18 years ago
Assigning to ekrock: 1/3 of Pierre's NEW bugs to help reduce his doomage factor
Assignee: pierre → ekrock

Comment 3

18 years ago
DUP of bug 12232.

*** This bug has been marked as a duplicate of 12232 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

18 years ago
Reassigned back to me these bugs that shouldn't have left my list.
Assignee: ekrock → pierre
Status: RESOLVED → NEW
Fixing resolution.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago

Comment 6

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.