POST REDIRECTION FAILS USING ASP

RESOLVED DUPLICATE of bug 178258

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 178258
12 years ago
12 years ago

People

(Reporter: Paul Gallagher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

we use the following ASP to redirect to some web pages and also collect data on
the way. The link above calls the web page mail_redirect.asp and the code for
that is below, this page collects the data and stores it and then moves on to
redirect.asp before being pushed onto the final web page. I do not pretend to be
an ASP expert but all this page does is store the data sent in the URL and that
is used in the redirect page. How can I change this to work with FireFox works
fine with IE and OPERA

<TITLE>E-MAIL REDIRECTION</TITLE>
<form method="POST" action="redirect.asp" name="MailRedirect"> 
<%'the request vars have been left to support v2.6
Zone = Request.QueryString.Item("Zone")
ContactID = Request.QueryString.Item("UserID")
Campaign = Request.QueryString.Item("Campaign")
Test  = Request.QueryString.Item("Test")
OpenEmail = Request.QueryString.Item("OpenEmail")
EMail = Request.QueryString.Item("EMail")
ON ERROR RESUME NEXT
If Len(Request.Form("Zone")) > 0 Then Zone = Request.Form("Zone")
If Len(Request.Form("ContactID")) > 0 Then ContactID = Request.Form("ContactID")
If Len(Request.Form("Campaign")) > 0 Then Campaign = Request.Form("Campaign")
If Len(Request.Form("Test")) > 0 Then Test = Request.Form("Test")
If Len(Request.Form("OpenEmail")) > 0 Then OpenEmail = Request.Form("OpenEmail")
If Len(Request.Form("EMail")) > 0 Then EMail = Request.Form("EMail")	
If Len(Request.Form("ActionType")) > 0 Then ActionType = Request.Form("ActionType")	

ON ERROR GOTO 0
%>
<input type="hidden" name="ContactID" value="<%=ContactID%>">
<input type="hidden" name="Campaign" value="<%=Campaign%>">
<input type="hidden" name="Zone" value="<%=Zone%>">
<input type="hidden" name="Test" value="<%=Test%>">
<input type="hidden" name="OpenEmail" value="<%=OpenEmail%>">
<input type="hidden" name="EMail" value="<%=EMail%>">		
<input type="hidden" name="Verified" value="<%=Verified%>">
<input type="hidden" name="ActionType" value="VERIFY">
<script language="javascript">
{
	document.MailRedirect.submit();
}
</script>
</form>

Reproducible: Always

Actual Results:  
nothing happens when it should move to another page

Expected Results:  
move to page redirect, then to a valid web page in this instance an unsubscribe page
*** Bug 300575 has been marked as a duplicate of this bug. ***
ASP doesn't mattert for us or other Browsers because ASP is scripting on the
server side. and the Browser gets only HTML.
in this case :
<TITLE>E-MAIL REDIRECTION</TITLE>
<form method="POST" action="redirect.asp" name="MailRedirect"> 
<input type="hidden" name="ContactID" value="C6UJ9A0000TX">
<input type="hidden" name="Campaign" value="Q6UJ9A0272NR">
<input type="hidden" name="Zone" value="Q6UJ9A0272T8">
<input type="hidden" name="Test" value="F">
<input type="hidden" name="OpenEmail" value="">
<input type="hidden" name="EMail" value="ben.holcombe@configuresoft.com">..
<input type="hidden" name="Verified" value="">
<input type="hidden" name="ActionType" value="VERIFY">
<script language="javascript">
{
.document.MailRedirect.submit();
}
</script>
</form>

The error from The Mozilla Javascript console is: 
Error: document.MailRedirect has no properties
Source File:
http://slx.configuresoft.com/e1Target/mail_redirect.asp?Test=F&Campaign=Q6UJ9A0272NR&Zone=Q6UJ9A0272T8&UserID=C6UJ9A0000TX&EMail=ben.holcombe@configuresoft.com
Line: 14

I don't know enough about DOM0 to tell you why this fails. I hope someone else can.

Comment 3

12 years ago
This is a duplicate.

*** This bug has been marked as a duplicate of 178258 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.