relatively positioned container with overflow hidden and padding will not render absolutely positioned children to the right correctly

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Darin Grimm, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050709 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Problem: Create a parent container which is relativley positioned with overflow
hidden and padding.Create a child within the container which is relatively
positioned to the right (right:0).The child should touch the right side of the
container, but DOESNT if overflow is set to hidden 

All very clearly shown in the attached test case.

This displays correctly in Firefox 1.0.x and Deer Park Alpha 1, it regressed
before Deer Park Alpha 2 was released.

Reproducible: Always

Steps to Reproduce:
1. try the test case
2. OR go to the website http://phonophunk.phreakin.com/news/ 
3.
(Reporter)

Comment 1

13 years ago
Created attachment 189225 [details]
testcase

Comment 2

13 years ago
You can see the problem in the header image on http://phonophunk.phreakin.com/news/

The header image is the container div. The shadows inside the container are
relatively positioned. The RIGHT side shadow is not touching the right side of
the aimge as it should.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
(Reporter)

Comment 3

13 years ago
Further investigation on regression dates:

It appears Deer Park Alpha 1 does not display the testcase correctly, meaning
the regression is older than that.  This increases the possibility this bug is a
dupe.  

A build from 5/7/05 displayed both the testcase and website incorrectly.  A
build from 3/1/05 displayed the website correctly but the testcase incorrectly
(but different) -- the blue line was shifted to the left right beside the green
line.

Quiting for tonight, more testing later...
The testcase works in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.9)
Gecko/20050709 Firefox/1.0.5, but not in Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.8b2) Gecko/20050606 Firefox/1.0+

Probably need to find a regression date.
(Reporter)

Comment 5

13 years ago
Okay, regression time frame is narrowed down.  Testcase works on build 20050207,
broke on build 20050208.  It appears the checkin for Bug 277420 caused this bug.
 However, further investigation makes me wonder if this bug isn't simply a
duplicate of 294934, I am CC'ing Robert for confirmation as this stuff is WAY
above my head :(

One other note, the website issue that caused this bug to be reported is NOT the
same as the testcase, the website issue works in later builds and that
regression was at a later date.  I am planning to file a seperate bug there once
I narrow down a regression window and hopefully someone can provide a testcase.
I think this is a duplicate of bug 294934.
Depends on: 294934

Comment 7

13 years ago
Created attachment 189379 [details]
more accurate testcase

Comment 8

13 years ago
I just attached a more accurate testcase resembling
http://phonophunk.phreakin.com/news/ more closely. As Darin Grimm stated, the
website issue was not exactly the same as the first testcase.
(Reporter)

Comment 9

13 years ago
Both testcases now work, as well as the original website.  Fairly certian patch
for Bug 294934 fixed this as well.  Thanks Robert!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.