Last Comment Bug 300929 - Certificate Policy extensions not supported
: Certificate Policy extensions not supported
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Libraries (show other bugs)
: 3.10
: All All
: P1 normal (vote)
: 3.12
Assigned To: Richard N. Freedman
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 09:43 PDT by Richard N. Freedman
Modified: 2007-11-09 14:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Richard's patch (9.11 KB, patch)
2005-07-15 12:16 PDT, Julien Pierre
no flags Details | Diff | Splinter Review

Description Richard N. Freedman 2005-07-15 09:43:29 PDT
The Policy Mappings, Policy Constraints, and Inhibit Any policy extensions are
not recognized. The code is present to parse the Certificate Policies extension,
but the extension is marked as unsupported.
Comment 1 Julien Pierre 2005-07-15 12:16:20 PDT
Created attachment 189450 [details] [diff] [review]
Richard's patch

As checked in on NSS_LIBPKIX_BRANCH .

Checking in certdb/certt.h;
/cvsroot/mozilla/security/nss/lib/certdb/certt.h,v  <--  certt.h
new revision: 1.30.6.1; previous revision: 1.30
done
Checking in certdb/cert.h;
/cvsroot/mozilla/security/nss/lib/certdb/cert.h,v  <--	cert.h
new revision: 1.53.10.3; previous revision: 1.53.10.2
done
Checking in certdb/polcyxtn.c;
/cvsroot/mozilla/security/nss/lib/certdb/polcyxtn.c,v  <--  polcyxtn.c
new revision: 1.6.10.1; previous revision: 1.6
done
Checking in util/secoid.c;
/cvsroot/mozilla/security/nss/lib/util/secoid.c,v  <--	secoid.c
new revision: 1.31.10.1; previous revision: 1.31
done
Checking in util/secoidt.h;
/cvsroot/mozilla/security/nss/lib/util/secoidt.h,v  <--  secoidt.h
new revision: 1.19.10.1; previous revision: 1.19
done

Note You need to log in before you can comment on or make changes to this bug.