Last Comment Bug 301039 - Top border threedhighlight one pixel too thick as well the as "click-down" menu (all, errors, warnings, etc.) not centered.
: Top border threedhighlight one pixel too thick as well the as "click-down" me...
Status: RESOLVED FIXED
: fixed1.8, polish
Product: Toolkit Graveyard
Classification: Graveyard
Component: Error Console (show other bugs)
: unspecified
: x86 Windows XP
-- trivial (vote)
: mozilla1.8final
Assigned To: Bryan
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 10:25 PDT by Bryan
Modified: 2016-06-29 11:02 PDT (History)
4 users (show)
mtschrep: blocking1.8b5+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Attachment showing the issues described in this BUG. (24.37 KB, image/png)
2005-07-16 10:27 PDT, Bryan
no flags Details
Polishes JavaScript Console and Help Viewer bringing them inline with 253661... (2.13 KB, patch)
2005-08-14 19:36 PDT, Bryan
kevin: review+
Details | Diff | Splinter Review
Slight improvement to code that fixes the evaluate button in the JCon I missed previously... (2.12 KB, patch)
2005-08-28 12:39 PDT, Bryan
kevin: review+
asa: approval1.8b4+
Details | Diff | Splinter Review
Address comment 10... (5.65 KB, image/gif)
2005-08-31 12:16 PDT, Bryan
no flags Details

Description User image Bryan 2005-07-16 10:25:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050716 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050716 Firefox/1.0+ ID:2005071608

Top border threedhighlight one pixel too thick as well the as "click-down" menus
(all, errors, warnings, messages, clear and evaluate) not centered.  The Help
Viewer also suffers from the Top border threedhighlight being one pixel too thick.

Reproducible: Always

Steps to Reproduce:
1. Download latest build (Deer Park)
2. Launch Deer Park
3. Click Tools-> JavaScript Console and or Help-> Help Contents
4. Observe the border above the "click-down" menus (all, errors, warnings,
messages, clear) is one pixel too thick as well as the "click-down" menus (all,
errors, warnings, messages, clear and evaluate) are not centered.  Observe in
the Help Contents that the border above the toolbar menu is one pixel too thick.
Actual Results:  
Observe the border above the "click-down" menus (all, errors, warnings,
messages, clear) is one pixel too thick as well as the "click-down" menus (all,
errors, warnings, messages, clear and evaluate) are not centered.  Observe in
the Help Contents that the border above the toolbar menu is one pixel too thick.

Expected Results:  
All highlight borders BELOW the title bar should MATCH the highlight border
below the title bar in the Firefox (Deer Park) main window as shown in the
attachment.  This also would apply to any extensions that display full windows
that are included in the firefox distribution (DOM Inspector, which is fine
BTW).  Only the JavaScript Console and the Help Viewer exhibit this issue.
Comment 1 User image Bryan 2005-07-16 10:27:31 PDT
Created attachment 189548 [details]
Attachment showing the issues described in this BUG.

Attachment showing the issues described in this BUG highlighted in red.
Comment 2 User image Bryan 2005-07-16 10:39:04 PDT
I forgot to mention that this only pertains to the default FF theme.
Comment 3 User image Bryan 2005-08-14 19:36:28 PDT
Created attachment 192709 [details] [diff] [review]
Polishes JavaScript Console and Help Viewer bringing them inline with 253661...

Polishes JavaScript Console and Help Viewer bringing them inline with 253661 in
terms of border/border highlight and menubar spacing / centering of text...
Comment 4 User image Kevin Gerich 2005-08-28 06:59:18 PDT
Comment on attachment 192709 [details] [diff] [review]
Polishes JavaScript Console and Help Viewer bringing them inline with 253661...

thanks for the ping. please excuse the delay

this looks fine on Windows Classic. At some point we should probably totally
remove the top highlight on the first menubar/toolbar in all windows just like
Windows Classic does.
Comment 5 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-08-28 11:13:48 PDT
Trunk:
mozilla/toolkit/themes/winstripe/global/toolbar.css; new revision: 1.8;
mozilla/toolkit/themes/winstripe/global/console/console.css; new revision: 1.7;
Comment 6 User image Bryan 2005-08-28 11:56:09 PDT
I discovered that I missed the evaluate button in the JCon and have modified the
code to address this issue:

#ToolbarMode .toolbarbutton-text {
  -moz-padding-start: 0px;
  -moz-padding-end: 5px;
}

BECOMES:

.toolbarbutton-text {
  -moz-padding-start: 0px;
  -moz-padding-end: 5px;
}

Gavin said there was no need for a new patch and that he would fix this on the
trunk as well as the patch that is attached himself.

~B
Comment 7 User image Bryan 2005-08-28 12:39:54 PDT
Created attachment 194115 [details] [diff] [review]
Slight improvement to code that fixes the evaluate button in the JCon I missed previously...

Code cleanup that fixes the "Evaluate" button I missed previously.
Comment 8 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-08-28 15:36:02 PDT
Checked in the correction on the trunk.
Comment 9 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-08-29 15:57:48 PDT
mozilla/toolkit/themes/winstripe/global/toolbar.css; new revision: 1.7.2.1;
mozilla/toolkit/themes/winstripe/global/console/console.css; new revision: 1.6.8.1;
Comment 10 User image Kevin Pilasky 2005-08-30 07:45:33 PDT
(In reply to comment #4)
> this looks fine on Windows Classic. At some point we should probably totally
> remove the top highlight on the first menubar/toolbar in all windows just like
> Windows Classic does.

Can this be done before 1.5 Final?
Comment 11 User image Bryan 2005-08-31 12:16:08 PDT
Created attachment 194458 [details]
Address comment 10...

(In reply to comment #4)
> this looks fine on Windows Classic. At some point we should probably totally
> remove the top highlight on the first menubar/toolbar in all windows just
like
> Windows Classic does.
>
> Can this be done before 1.5 Final?

This was added intentionally as part of bug 253661.  I personally believe it
should stay as our goal was to replicate IE in terms of toolbar and menu
spacing.

~B
Comment 12 User image Ben Goodger (use ben at mozilla dot org for email) 2005-09-02 12:36:17 PDT
I had to remove the toolbar.css part of this patch since it added an unnecessary
groove at the top of every window. I did this on the branch and the trunk. Sorry
Gavin!

Note You need to log in before you can comment on or make changes to this bug.