Go to http://www.kemi.se, view page source, scroll to right and firefox crash (always).

RESOLVED INVALID

Status

Core Graveyard
View Source
--
critical
RESOLVED INVALID
13 years ago
8 years ago

People

(Reporter: ericwyzerski, Assigned: mrbkap)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.8) Gecko/20050512 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.8) Gecko/20050512 Firefox/1.0.4

Go to http://www.kemi.se, view page source, scroll to right and firefox crash
(always). I cant test on another platform but other solaris user told me that it
crash on their system too. Maybe it will help to find why firefox crash many
times a day on solaris. It is a firefox bug, last version of mozilla work fine
(with the example)

Reproducible: Always

Steps to Reproduce:
1. go to http://www.kemi.se
2. View page source
3. Scroll to right

Actual Results:  
Firefox core dump, log from truss:
readv(4, 0xFFBE3D90, 2)                         = 6088
    Incurred fault #6, FLTBOUNDS  %pc = 0xFE61EF04
      siginfo: SIGSEGV SEGV_MAPERR addr=0xFF3EFFDC
    Received signal #11, SIGSEGV [caught]
      siginfo: SIGSEGV SEGV_MAPERR addr=0xFF3EFFDC
        *** process killed ***

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050716 Firefox/1.0+
ID:2005071622

Work for me.
(Reporter)

Comment 2

13 years ago
Close this bug please, I am wrong this is  a mozilla bug not a firefox bug.
thank you

Comment 3

13 years ago
*** Bug 301100 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Component: General → ViewSource
Product: Firefox → Mozilla Application Suite

Comment 4

13 years ago
WFM, SeaMonkey 2005-07-11-02 trunk Linux.

On the page there is a <input type=hidden value="..."> where the value has 7756
characters which could be the cause for the crash...

ericwyzerski@hotmail.com: if you save the page to a local file does it still
crash? if so, does the crash go away if you change it to value="" ?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> WFM, SeaMonkey 2005-07-11-02 trunk Linux.
> 
> On the page there is a <input type=hidden value="..."> where the value has 7756
> characters which could be the cause for the crash...
> 
> ericwyzerski@hotmail.com: if you save the page to a local file does it still
> crash? Not when saving the page, but after when I open the page locally and I
try to see the source and I scroll to right, it crash.

>if so, does the crash go away if you change it to value="" ? Yes, If I replace
the 7765 character by "", mozilla dont crash.
 

Updated

13 years ago
Keywords: crash

Comment 6

13 years ago
./mozilla -d dbx -g
run
{crash}
where

can you at least provide the output from where?
Assignee: nobody → mrbkap
QA Contact: general → doronr
*points at comment #2*

(In reply to comment #7)
> *points at comment #2*

No, see comment 5.

*****

ericwyzerski,

Can you reproduce with SeaMonkey v1.1.9 ?

Comment 9

10 years ago
It didn't crash for me.
I was using Firefox 3 Beta 5.
(In reply to comment #4)
> On the page there is a <input type=hidden value="..."> where the value has 7756
> characters which could be the cause for the crash...

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.13) Gecko/20060414] (release) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)

|<input type="hidden" name="__VIEWSTATE" value="..." />| is 22,7xx char long :->

But no crash, on Windows 2000.

*****

(1 month later)

No (more) reply from (initial) reporter.

(Would have been "Incomplete", now is) R.Invalid

Reopen if you can reproduce with SeaMonkey v1.1.9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.