giving colgroup and/or col elements properties like align or css text-align has no effect

RESOLVED DUPLICATE of bug 915

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 915
14 years ago
14 years ago

People

(Reporter: bgrupe, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050717 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050717 Firefox/1.0+

According to the HTML4 spec, <col align="right"> for example should align the
text in the given col right. WFM in MSIE, Opera, doesn't work with Gecko browsers.

Using CSS text-align doesn't work either.

Reproducible: Always

Steps to Reproduce:
1. Create a table with a col giving it align="center" OR: CSS text-align: center

Actual Results:  
The column contents are aligned left (the default).

Expected Results:  
The column contents are centered.

This helps writing less code and more semantic code.
(Reporter)

Comment 1

14 years ago
Created attachment 189605 [details]
Modified w3 sample table

I modified the W3 sample table (see URL) and added CSS text-align to
demonstrate that the CSS approach doesn't work either.
(Reporter)

Updated

14 years ago
Component: HTML: Parser → Layout: Tables
Assignee: parser → nobody
QA Contact: mrbkap → layout.tables

*** This bug has been marked as a duplicate of 915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.