Closed Bug 301123 Opened 17 years ago Closed 10 years ago

Custom profile creation should allow for separate profile and cache folder selection

Categories

(Toolkit :: Startup and Profile System, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Geert.Poels, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Rather than having to joggle with the profile manager and prefs.js, I'd would be
really really handy if the FF Installer would allow for the selection of the
cache and profile folder.
There's a default profile installed the first time anyway.
This would be a option of the custom installation :-)
If there would be a fear to confuse less computer savvy users, then make it
available through something like 'other options' in the custom installation tab.

I'm using Deer Park Alpha 2

Reproducible: Always
I work for Texas A&M University in a department that supports the Open Access 
Labs.  I too would like to see some sort of option that allows at minimum an 
enforceable redirection of the cache folder. We use windows roaming profiles 
and we find that the cache folder loads up the users profile thus extending 
log in and log out times.  At some point the profile becomes so full that the 
user can not log off due to hard quota limits we have had to put in to place 
for profiles and home drives for our users. I would honestly prefer that the 
entire profile be relocateable and allow the ability to seperate out the cache 
files so they are not stored in our users home drives or roaming profiles.  

For this reason, it is not logistically possible for us to install Firefox in 
our Open Access computing labs.  We can not count on users to create profiles 
and then move them or fix them via the profile manager on their own.  We have 
done some custom prefs.js files and profiles with little success because there 
is no global setting forcing redirection.  The users would make a few changes 
in the preferences and we found ourselves with students that could not log out 
because their roaming profile was too big after the profile folder was put 
back in to their profile. 
(In reply to comment #0)
> ...
> There's a default profile installed the first time anyway.
No profiles are ever installed by the installer. This is provided by the applications themselves and is created on first run.

Before the installer could even provide an option for this on install the applications will need to support reading / using values that tell it where the profile and cache folders are to be located. It may be possible to have the installer create a profiles.ini for one location on install but subsequent profiles would not by default be created in that location as well as it wouldn't affect other users on a multi-user system. Also, there is no way to specify the cache location via the installer since on a clean install there is no profile to modify this information though it may be possible to add a pref file that would override the default.

Changing the component to OS Integration since the installer can't do a thing with this until the applications support it.
Component: Installer → OS Integration
QA Contact: installer → os.integration
Over to startup and profile system since this is part of profile creation
Component: OS Integration → Startup and Profile System
QA Contact: os.integration → startup
Summary: Custom installation should allow for separate profile and cache folder selection → Custom profile creation should allow for separate profile and cache folder selection
Product: Firefox → Toolkit
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.