The default bug view has changed. See this FAQ.

crash if you stop search and hit the search button again (Mozilla 1.7 only)

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Marten Lehmann, Unassigned)

Tracking

({crash, fixed1.7.12})

1.7 Branch
x86
Windows XP
crash, fixed1.7.12
Bug Flags:
blocking1.7.12 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

The whole mozilla suite crashs if you search for a string in message bodies,
stop the search and start the search again.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla Mail
2. Select Tools -> Search Messages
3. Keep default settings, but change type "Subject" to "Body"
4. enter something to look for
5. hit the search-button
6. hit the stop button while the search is going on (choose a larger folder if
search is ending too fast)
6. hit the search-button again
7. mozilla crashes

Actual Results:  
The whole suite crashes.

Expected Results:  
The search should start as it does after the first hit of the search-button.

I'm using mozilla 1.7.8, thus the most current public release.

Updated

12 years ago
Severity: major → critical
Keywords: crash
Do you have a talkback incident ID for this crash?  Please find and run
talkback.exe and see if you do, then paste the incident ID # in here, or look it
up on http://talkback-public.mozilla.org and paste the stack trace in here.  Thanks.
bug 283848 is similar, just waiting on a stack.

Comment 3

12 years ago
*** Bug 308090 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
I found out that this was fixed for TB on the Aviary 1.0.1 branch with Bug
254199, but not for the Mozilla 1.7 branch. Trunk and 1.8 branch have the patch too.

fix is in
1.8 branch & Trunk (TB 1.5x/SeaMonkey 1.0x)
http://lxr.mozilla.org/mozilla1.8/source/mailnews/base/search/src/nsMsgSearchTerm.cpp#1433
http://lxr.mozilla.org/seamonkey/source/mailnews/base/search/src/nsMsgSearchTerm.cpp#1433
Aviary 1.0.1 branch (TB 1.0.x)
http://lxr.mozilla.org/aviary101branch/source/mailnews/base/search/src/nsMsgSearchTerm.cpp#1430

but NOT in
1.7 Branch (Mozilla Suite 1.7.x)
http://lxr.mozilla.org/mozilla1.7/source/mailnews/base/search/src/nsMsgSearchTerm.cpp#1430

This crasher should be easy to fix for Mozilla 1.7.12.

related, probably the same bug 291970 (stop search while in progress)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.7.12?
Summary: crash if you stop search and hit the search button again → crash if you stop search and hit the search button again (Mozilla 1.7 only)
Version: unspecified → 1.7 Branch

Comment 5

12 years ago
Created attachment 195845 [details] [diff] [review]
port the fix to the 1.7 branch

very low risk fix for something that's been in the aviary 1.0 branch for quite
some time.
Attachment #195845 - Flags: superreview?(dbaron)

Updated

12 years ago
Flags: blocking1.7.12? → blocking1.7.12+
Comment on attachment 195845 [details] [diff] [review]
port the fix to the 1.7 branch

This is exactly the same as the patch on the other bug. :-)
Attachment #195845 - Flags: superreview?(dbaron)
Attachment #195845 - Flags: superreview+
Attachment #195845 - Flags: approval1.7.12+

Comment 7

12 years ago
fixed on the 1.7 branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.7
Resolution: --- → FIXED

Updated

12 years ago
Keywords: fixed1.7 → fixed1.7.12

Comment 8

12 years ago
Verified?

Comment 9

12 years ago
*** Bug 291970 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
You need to log in before you can comment on or make changes to this bug.