page-break-before does not work !

RESOLVED DUPLICATE of bug 136714

Status

()

RESOLVED DUPLICATE of bug 136714
13 years ago
13 years ago

People

(Reporter: ax4004, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I know there are many reports of this bug, but the fact is it still does not 
work even on the latest Firefox download.
I have tried <tr style="page-break-before:always;">, and with it inside <p> and 
other places and it does not produce a page break on print preview.  I'm sure 
you've heard this before but it works on I.E.

Reproducible: Always

Steps to Reproduce:
1.add page-break-before:always; somewhere
2.do a print preview
3.hey presto, it doesn't work !

Actual Results:  
it doesn't work !

Expected Results:  
start a new page in printing and print preview.
Bug 24000 seems to indicate that this has been fixed for some time now and the
testcase there works for me.

Please provide a testcase that shows the problem you are experiencing.

Comment 2

13 years ago
As said, please provide a testcase.

If I remember the spec correctly, page-brake-* is only specified on block level
elements.

Bug 24000 implements page-break-before:always, remaining issues are in bug 132035. 

Comment 3

13 years ago
If this boils down to page-break on table elements, it's a dupe of bug 136714.
(Reporter)

Comment 4

13 years ago
thanks for the relies.

The following code is how I use it, it fails to print or print preview the text 
on the next page.

<table border="0" width="600" height="800"  cellspacing="0" cellpadding="0" 
align=center bgcolor="#FFFFFF">
  <tr style="page-break-before:always;">
    <td valign=top>
      <font size="4">This should be on a new page<\font>
   </td>
  </tr>
</table>

I have also tried <p style="page-break-before:always;">Hello</p> which works on 
IE but not Firefox.

regards.
As per comment 3, duping to bug 136714

*** This bug has been marked as a duplicate of 136714 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.