Status

()

--
enhancement
RESOLVED DUPLICATE of bug 217199
14 years ago
5 years ago

People

(Reporter: u209431, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

A whitelist of cookies by domain would be appreciable. For instance, I don't
want cookies from sites such as Alexa, but useful cookies from MediaWiki
Foundation projects are good. I suggest a whitelist, configurable from
Options>Privacy, and one of those yellow bars which tell the user something's
been blocked, and a link on the bar to the whitelist, as with popups and extensions.

Reproducible: Always

Steps to Reproduce:
n/a
Actual Results:  
n/a

Expected Results:  
n/a

*** This bug has been marked as a duplicate of 75915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Could you be more specific? You can already do almost everything you ask for.

- the "Exceptions" button on the pref-panel you mention leads to a list where
you can put sites on a white or black list (allow or block).

- you can have Firefox ask you for each cookie, which makes it easy to put sites
on the white or black list.

- if you set the main pref to block it still will do cookies for sites already
on the "allow" list (a whitelist).

So is this bug just a UI RFE about getting an infobar or status bar widget
notification when a cookie has been blocked?
Component: Security → General
I don't see how this Firefox bug could be a duplicate of a Suite UI bug. I agree
it sounds like the same concept, but a fix for Firefox would require a different
patch in different files.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

14 years ago
(In reply to comment #2)
> Could you be more specific? You can already do almost everything you ask for.
> 
> - the "Exceptions" button on the pref-panel you mention leads to a list where
> you can put sites on a white or black list (allow or block).

True, but it's not labelled as such. The button merely says "'exceptions' [to
this rule]" which means "sites to block."

> 
> - you can have Firefox ask you for each cookie, which makes it easy to put sites
> on the white or black list.

Horrifyingly inconvenient - I just want to block them all, except those on my
whitelist.

> - if you set the main pref to block it still will do cookies for sites already
> on the "allow" list (a whitelist). So is this bug just a UI RFE about getting
an infobar or status bar widget notification when a cookie has been blocked?

I suppose it is. It shouldn't be too hard to implement.

PS I really am called Ben Goodger, which is very annoying in mozdev.

Comment 5

14 years ago
Possibly related to bug 255199 and bug 217199.
QA Contact: firefox → general

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 217199
You need to log in before you can comment on or make changes to this bug.