Closed Bug 301985 Opened 14 years ago Closed 4 years ago

Fixing warnings

Categories

(NSPR :: NSPR, defect)

Other
FreeBSD
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 302152

People

(Reporter: mi+mozilla, Assigned: wtc)

References

(Blocks 1 open bug)

Details

(Whiteboard: [build_warning])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.4; FreeBSD; X11; amd64) KHTML/3.4.1 (like Gecko)
Build Identifier: 

A number of trivial warnings prevent nspr-code from compiling cleanly with 
-Wall -Werror. This makes use of these compiler options difficult, when 
searching for real bugs. 

Reproducible: Always
Attached patch Fix the easiest warnings (obsolete) — Splinter Review
Attachment #190368 - Attachment is obsolete: true
QA Contact: wtchang → nspr
Whiteboard: [build_warning]
Is this dup. of bug 302152?
Flags: needinfo?(mi+mozilla)
(In reply to Takanori MATSUURA from comment #3)
> Is this dup. of bug 302152?

So it would seem, yes, but -- 10 years later -- I am not certain...
These NSPR patches from 2005 are no longer relevant. NSPR warnings should be fixed upstream.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(mi+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 302152
(In reply to Chris Peterson [:cpeterson] from comment #5)
> These NSPR patches from 2005 are no longer relevant.

Unfortunately, NSPR still generates TONNES of compiler-warnings today, 10 years later... Here are the up-to-date patches as used by the FreeBSD port. The patches aren't FreeBSD-specific and ought to be merged into release:

https://svnweb.freebsd.org/ports/head/devel/nspr/files/patch-warnings?view=log
https://svnweb.freebsd.org/ports/head/devel/nspr/files/patch-tests?view=log
https://svnweb.freebsd.org/ports/head/devel/nspr/files/patch-libtests?view=log

> NSPR warnings should be fixed upstream.

What is "upstream" here? Is NSPR no longer a Mozilla product?
(In reply to Mikhail T. from comment #6)
> (In reply to Chris Peterson [:cpeterson] from comment #5)
> > NSPR warnings should be fixed upstream.
> 
> What is "upstream" here? Is NSPR no longer a Mozilla product?

Good question. By "upstream", I meant not in the mozilla-central Mercurial repo. NSPR and NSS are maintained in a CVS repo shared by some non-Mozilla projects, independent of Firefox code.
You need to log in before you can comment on or make changes to this bug.