Russian autodetection module corrupts data

VERIFIED DUPLICATE of bug 23920

Status

()

P3
normal
VERIFIED DUPLICATE of bug 23920
19 years ago
19 years ago

People

(Reporter: mik, Assigned: ftang)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If Russian characterset autodetection module detects windows-1251 encoding

it corrupts some characters



Detection itself is done correctly.



Linux M14 release and all previous releases.

 (by the way, it reports that is is M13, but it IS M14)
(Assignee)

Comment 1

19 years ago
please prvide more detail. The information is not enouge for track down the 
problem. Please include url , and point out where gwt corrupt
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 2

19 years ago
url: http://www.chel.com.ru/~mik
there the files koi8.html and win1251.html do contain meta headers for
encodings, and *-noencoding do not contain them.
If autodetect is off, pages with metas are displayed properly, pages without
weta are displayed properly if I chouse encoding manually.

Now, if I turn on Autodetection (Russian), all the pages are being displayed
properly except for win2151-nometa, which is correctly autodetected,
but some characters are damaged.
(Assignee)

Comment 3

19 years ago
I am really supprise that you claim "which is correctly autodetected," !!! I 
have not fix bug 23920 yet. There are no way it can detect as windows-1251 
untill that bug got fixed.
I think this is simply a dup of 23920.

Depends on: 23920
(Assignee)

Comment 4

19 years ago
add the url to the URL field
(Assignee)

Comment 5

19 years ago
I see everything correctly in my private build which have the fix of 23920 which 
I will check in soon. (sorry, not in beta1)
In my Mac which do not have that fix, I see the first two line convert 
incorrectly but the third line seems ok. I think what happen is the detector 
detect the page as x-mac-cyrillic and happen the third line are identical in 
windows-1251 and x-mac-cyrillic.

Mark this as dup of 23920

*** This bug has been marked as a duplicate of 23920 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.