Mozilla fails one W3 CSS validation test.

VERIFIED DUPLICATE of bug 18936

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 18936
18 years ago
18 years ago

People

(Reporter: Robert Hencke, Assigned: Pierre Saslawsky)

Tracking

({css1})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I'm currently using Build 2000030215 running under Windows 98.

If you go to http://www.w3.org/Style/CSS/Test/current/sec15.htm you'll notice
Mozilla fails the test saying "This sentence should be black, not red-- ID
selectors cannot begin with digits in CSS1."  Mozilla displays the sentence in
red, instead of black.

I have not tried validating this under MacOS or Linux.

Comment 1

18 years ago
Adding CSS1 to keywords, as given URL tests CSS1 compability.
BTW: NS4 displays right.
Keywords: css1
OS: Windows 98 → All
Hardware: PC → All

Comment 2

18 years ago
Confirmed on Linux build 2000.03.07.09. -> Style System
Assignee: rickg → pierre
Status: UNCONFIRMED → NEW
Component: HTML Element → Style System
Ever confirmed: true
QA Contact: petersen → chrisd
(Assignee)

Comment 3

18 years ago
This is a CSS1 test page but per CSS2, the display is correct.
See bug 18936 for the whole story. Also related are bug 22434 and bug 15868.


*** This bug has been marked as a duplicate of 18936 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.