Compatibility issue between embeded Mozilla and its users

RESOLVED DUPLICATE of bug 302162

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 302162
13 years ago
3 months ago

People

(Reporter: westlookbird, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20050606
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20050606

We have embedded Mozilla in our project using xpcom APIs.

But we meet a big compatibility problem which is caused by the gcc compilers'
ABI change.
If Mozilla and our project are built by different version gcc with different ABI
version, the program will not work Sad .

That's really a depression and we have made lots of tries to solve that, but we
still don't have a good solution.

So, could mozilla document that build with gcc3.x or above should use ABI1 ?
That's will be very helpfulto solve the compatibility problem. And further more,
many other projects depend on mozilla will definitely
benefit from that too.

thanks,
Michael

Reproducible: Always

Updated

13 years ago
Component: Build Config → Build Config
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 302162 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.