Closed Bug 302277 Opened 19 years ago Closed 19 years ago

Per-word text navigation doesn't work properly

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 190615

People

(Reporter: craig, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050727 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050727 Firefox/1.0.6

Under firefox on windows or mac, I can move to the end of the location bar and
press [MOD]+LEFT in order to scroll back a part-word. Thus - the cursor will go
back to the space or some forms of punctuation (eg: slashes). [MOD]+RIGHT moves
forward to the nearest space or some punctuation. Firefox under linux doesn't
support this properly. Ctrl+left or ctrl+right will skip only to the next space.
This is quite annoying, because when you use several firefox environments you
get used to loading a bookmark, going to the end of the line, then pressing
ctrl+left a few times to edit rid of the last parts of the path.

Would somebody please implement this missing functionality in all text widgets
in the engine for the linux codebase? The Windows implementation would be the
best reference, I think.



Reproducible: Always

Steps to Reproduce:
1.Move to the location bar. Imagine the URL is
https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox
2.Hold shift and ctrl+left in expectation it will highlight the block to the
previous slash.
3.Destroy prescious URL by accident
4.Upon discovery of what's happened, use both hands to tug at hair with
sufficient vigour to remove clumps. (actually, it hasn't been that bad since the
team implemented ctrl+z :) )

Actual Results:  
After step 2, the highlighted block was the entire link in the location bar

Expected Results:  
After step 2, the highlighted block should have been the token "Firefox".

This has always been a problem with all netscape browsers I've used on netscape
since the dawn of time.
No offense is intended by anything I've written here btw. When I wrote it I was
replying to forms, and some of the remarks feel far less appropriate now they're
rendered without the comments. :/
Duplicate of Core bug 190615.
(In reply to comment #2)
> Duplicate of Core bug 190615.

Indeed.

*** This bug has been marked as a duplicate of 190615 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.