Closed Bug 302383 Opened 17 years ago Closed 17 years ago

component contained in JavaScript will not be executed (property not retrieved)

Categories

(Toolkit :: View Source, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 226193

People

(Reporter: ben__arthur, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

How to duplicate this 100%

please see the step given
Properties is not returning any information

if you need more information please let me know 
also please acknolegde if you receive this report
just let me know if it will be looked at or not 

Ben 




Reproducible: Always

Steps to Reproduce:
Step #1
create a new HTML page
Step #2
include the following line
<script language="JavaScript">
function propertiesBen(){
var sProps = "document Properties\n";
for (props in document)
sProps += props + ": " + document[props] + "\n";
alert(sProps)
}
propertiesBen()
</script>
step #3
Load the page in Firefox
========================================
   THIS IS WHERE THE ISSUE OCCURS
   {  or not for this instance :-)  }
========================================


Actual Results:  
Javascript: return the following
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOM3Document.domConfig]"  nsresult:
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
file:///C:/Documents%20and%20Settings/ben/Desktop/test.html :: propertiesEric ::
line 10"  data: no]

Expected Results:  
One would expect to see an alert screen with all the properties of the document
instead ...nothing
DUP of Bug 226193. See Bug 291377 also.

Workaround: Use "try / catch" as script in Bug 226193 / Bug 291377 does.
If no access to the property of the NS_ERROR_NOT_IMPLEMENTED one, listing can be
done.
  var obj_string;
  for (props in document) {
   try      { obj_string = document[props] ; }
   catch(e) { obj_string = "Unimplemented?"; }
   sProps += props + ": " + obj_string + "\n";
  }


*** This bug has been marked as a duplicate of 226193 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.