The default bug view has changed. See this FAQ.

Flash Action Script, loadMovie("file:///D:/a_folder_on_cd/test.swf",holder) not working.

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 84128
12 years ago
12 years ago

People

(Reporter: Alan, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716

I have developed a Flash "linker" file which should locate a CD-ROM in a 
user's CD drive and open a file from that CD-ROM. It locates the user's CD 
drive letter by looping through "c" to "z", knowing it has found the CD-ROM 
when it locates a file called "test.swf" on the CD-ROM. This works fine in 
Mozilla 1.4.2, but does not work in Mozilla 1.7.8 and 1.7.10. These versions 
are not finding the test.swf file from the Action Script code within linker.swf
It tries both loadMovie("file:///D:/a_folder_on_cd/test.swf",holder)
and loadMovie("D:/a_folder_on_cd/test.swf",holder).
Is the filepath for some reason different in the later versions of Mozilla?

Reproducible: Always

Steps to Reproduce:
1.I upload my linker files to a website (e.g. 
http://www.deakin.edu.au/~alann/tnz_linker/linker.html).
2.I type this URL into Mozilla 1.7.8.
3.The linker.html file (containing my linker.swf file) opens and linker.swf 
tries to locate the test.swf file on the CD-ROM.
Actual Results:  
Mozilla 1.7.8 fails to locate the test.swf file on the associated CD-ROM, (as 
if it cannot understand the Action Script code
loadMovie("file:///D:/a_folder_on_cd/test.swf",holder),
whereas this worked every time with Mozilla 1.4.2.

Expected Results:  
Mozilla 1.7.8 and 1.7.10 should work the same as Mozilla 1.4.2 does.

I can only assume from the problem I am having that Mozilla 1.7.8 and later do 
not understand a filepath in the same way as earlier versions. Either this or 
it cannot understand the Action Script "loadMovie()". If the former is the 
case, how should the file path be structured for Mozilla 1.7.8 to understand 
it? If the latter is the case, this is a serious fault.

Comment 1

12 years ago
You have a remote (http://...) page open and try from there to open the local
file? This should be blocked. You can see the errors in the Javascript console
window.

Security Error: Content at
http://www.deakin.edu.au/~alann/tnz_linker/linker.html may not load or link to
file:///C:/pdfs/test.swf.
...
Security Error: Content at
http://www.deakin.edu.au/~alann/tnz_linker/linker.html may not load or link to
file:///Z:/pdfs/test.swf.

That would be Bug 84128. Was introduced with Bug 69070 for Moz 1.7.5. How to
change this behavior see
http://www.mozilla.org/releases/mozilla1.8a5/known-issues.html#psm



*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.