When appliying opacity in javascript to an iframe this cause a reload of the iframe

RESOLVED DUPLICATE of bug 159229

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 159229
13 years ago
10 years ago

People

(Reporter: n.escuder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

When an opacity is apply on an iframe the iframe reload the content or restart
javascript not just appliying the opacity ..

Reproducible: Always

Steps to Reproduce:
1. Try the code : 

<iframe id="ifrm" src="http://www.time.com/time/" width=500 height=500></iframe>
<script>
setTimeout("opacity(.5);", 5000);
function opacity(value) {
   var ifrm=document.getElementById("ifrm");
   ifrm.style.MozOpacity = value;
   if (value == .5)
      setTimeout("opacity(1);", 5000);
   else
      setTimeout("opacity(.5);", 5000);
}
</script>

2. You can see the phrase : "Special attractions moving to the top", the script
always restart ... :(




Expected Results:  
no reload just change the opacity

email me for more information if you need
(Reporter)

Comment 1

13 years ago
oups the url in  the test script must be
"http://www.itbhu.ac.in/spardha/frame.htm" not "http://www.time.com/time/"
Created attachment 305995 [details]
slightly polished version of original test case

There seem to be some updates.

Still occurs in Firefox 2: scroll position is lost during opacity toggling; text entered into the search input isn't lost though. Apparently fixed in Firefox 3. Version details bellow.

Seems to be somehow related with bug 254144 - although in this case DOM position isn't touched, DOM is here also manipulated (while changing iFrame's opacity). This suggests a more general issue, and a similar comment will also be attached there referring this bug.


Versions:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12 FireShot/0.32

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022604 Minefield/3.0b4pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159229
You need to log in before you can comment on or make changes to this bug.