Calling with -remote openURL always produces error 500

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Christopher Neufeld, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+

I'm using Deer Park Alpha 2, cvs checkout from the morning of June 28, 2005.  I
have compiled only the firefox component, and installed it.  I find that, when I
already have a firefox running, I can run:
firefox -remote "ping()"
but I cannot run any variant on openURL() or openFile().  In all cases, the
following error is reported:

$ firefox -remote "openURL(http://www.cneufeld.ca/neufeld,new-tab)"
Error: Failed to send command: 500 command not parseable


Reproducible: Always

Steps to Reproduce:
1. Start firefox
2. Execute the command 'firefox -remote "openURL(...), optionally with the
new-tab or new-window modifiers

Actual Results:  
An error message was returned:
Error: Failed to send command: 500 command not parseable

Expected Results:  
A new tab should have been opened on my running browser, and the content of the
URL opened therein.

Compiled on gcc-3.4.3 from cvs checkout of July 28, 2005 at approximately 09h00 EDT.

Comment 1

13 years ago
I'm seeing the same thing on Linux and Solaris. I can add that the problem is on
the receiving side, not the sending side, since I don't see it when a new
firefox issues a "-remote" against an old firefox.

Also when I compile with debug this is what shows up on the receiving side:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'Abort' when calling method: [nsICommandLineHandler::handle]" 
nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "<unknown>"  data: no]
************************************************************

Comment 2

13 years ago
Still present as of Deer Park Alpha 2, 20050804 build.

I think that (a) enough people have see this that it's higher than
"unconfirmed", and (b) it ranks as a "major" not "normal" - integration with
anything else that wants to pass a URL for display is busticated (I've seen it
with both 'gaim' and 'exmh', and anything *else* that uses the -remote scheme is
almost certainly hosed as well.
(Reporter)

Updated

13 years ago
Keywords: regression
(Reporter)

Comment 3

13 years ago
This has apparently been fixed.  A checkout and compile from two days ago works
as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.