{inc}table expands on onmouseover and onmouseout

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: ratman, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

13 years ago
i'm not sure if i have the right component here, but here goes.  this occurs
with both firefox 1.0.6 and deer park a2 on winxp.

1) go to http://www.bluetights.net
2) mouse over one of the links, but not one of the links in the left column.

expected behaviour:
the white main table remains the same height.

actual behaviour:
on mouseover and mouseout, the table grows in height - lines appear to be added
on the bottom of the table.  normally reloading the page not only returns the
table to the correct height, it also stops the behaviour from occurring again. 
hard reloading (ctrl-shift-r) resets the table to the correct height but causes
the mysterious table growing problem to reoccur.

i have no clue what's causing this - i'll try to pour over the source some more,
but i'm lost.
(Reporter)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050730 SeaMonkey/1.0a

The bug is seen, if I save the page as Webpage, complete, load it,
- do a Shift-Reload, then scroll down, then hover over the links.
- the growing stops if I do a reload.

Removing that link and the bug can't be reproduced:
<link rel="alternate" type="application/rss+xml" title="RSS 2.0"
href="http://www.bluetights.net/feed.xml" />

Currently I don´t have the time to make a testcase.
 

Comment 3

13 years ago
Created attachment 191129 [details]
reduced testcase

The test depends on a link, so you must be online, I assume.
Steps to repeat:
Download testcase

1. Load testcase
2. Shift-Reload
3. Scroll so you can see the slider moving, when in step 4 the table grows.
4. hover over links and see table grow.

Removing this stops the bug:
		<link rel="alternate" type="application/rss+xml" title="RSS
2.0" href="http://www.bluetights.net/feed.xml">
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 4

13 years ago
Created attachment 191310 [details]
more reduced testcase

reduced a bit further, still much room to improve.
removed one outer table. The DIV in the most inner table held two tables, when
I removed the second, the bug was gone, so I duplicated the first one.
I also couldn't remove the images.

Updated

13 years ago
Attachment #191129 - Attachment is obsolete: true

Comment 5

13 years ago
Steps to repeat:

1. Load testcase attachment 191310 [details]
2. Do a Shift-Reload
3. Hover over links to see the slider of the scrollbar shrink = page grows

Load/Reload disables growing, Shift-Reload enables growing.
Keywords: testcase

Comment 6

13 years ago
Created attachment 191317 [details]
more reduced testcase

removed RSS feed, replaced images with Mozilla.org images.

A:link	{ color: #4573b3; font-weight: bolder; }
A:hover { color: red;  font-weight: bold;} 

If font-weight is the same, the page doesn't grow on hovering.
If page is loaded from cache (Load/Reload), the page doesn't grow on hovering.
If page is loaded fresh (Shift-Reload), the page grows on hovering.

Bug may also depend on the height of the page, as it didn't work when I removed
a couple of links.
Attachment #191310 - Attachment is obsolete: true
Summary: table expands on onmouseover and onmouseout → {inc}table expands on onmouseover and onmouseout
(Reporter)

Comment 7

13 years ago
thanks, hermann, for picking this up and making the testcase.

as far as i can tell, it's the height="100%" in the second table that's key here
- the problem does not reoccur in the testcase after removing it.

Comment 8

13 years ago
(In reply to comment #7)
> thanks, hermann, for picking this up and making the testcase.
> 
> as far as i can tell, it's the height="100%" in the second table that's key here
> - the problem does not reoccur in the testcase after removing it.

You also can remove other things, and the problem is gone.
The art of reducing is not to find what can be removed to solve the problem, but
what can be removed without solving the problem.

The problem doesn't occur when loaded from cache (Load/Reload)
Hovering over links changes font-weight between 'bold' and 'bolder', and that
lets the 2nd Table with height="100%" grow.

Seems only one link is needed, if I replace the others with <br>
Seems an image is needed, I couldn't replace the image by a group of <br> tags

I'll attach a nearly minimal testcase next, showing table borders.
Feel free to reduce it more.
I don`t know how much <br> are needed, when I removed <hr> I had to insert <br> 

Comment 9

13 years ago
Created attachment 191402 [details]
nearly minimal testcase

Bug only seen after Shift-Reload, when cached.
one image is needed, can't be replaced by a number of <br> giving the height.
two tables in the div are needed.
one link is sufficient, if the height is made with <br>


<table bgcolor="white" border="0" cellpadding="0" cellspacing="0" height="600"
width="750">
      <table border="0" cellpadding="0" cellspacing="0" height="100%"
width="625">
		  <div align="center"><br>
		  <table border="0" cellpadding="0" cellspacing="0"
width="130">
		  <table border="0" cellpadding="0" cellspacing="0"
width="130">
		  </div>
Attachment #191317 - Attachment is obsolete: true
(Reporter)

Comment 10

13 years ago
i think you may have to rewind testcases.  somewhere between the first and
second testcases the behaviour changed - if you continue to mouseover the links
in the second testcase, the table grows but eventually it snaps back to the
correct size and the problem does not reoccur.  with the first testcase, the
table continues growing without ever resetting.

Comment 11

13 years ago
Created attachment 191584 [details]
minimal testcase

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050803 SeaMonkey/1.0a
Screen resolution 800x600

Bug seen on first Load and Shift-Reload.
There must be a 100% high table holding a DIV, the DIV must hold two tables,
there  must be at least one image and one link in one of the tables.
The DIV needs a minimum heigth, so I added a lot of <br>.

If bug isn't seen, add some more in the DIV or one of the tables therein.

Comment 12

13 years ago
It looks like it is some pct height observer stuff, the problem should not be
visible in standards mode as the pct height observer requires quirks mode.
(Reporter)

Comment 13

13 years ago
Created attachment 191852 [details]
new minimal testcase

took out the <div> and replaced with a <br>.
Attachment #191584 - Attachment is obsolete: true
(Reporter)

Comment 14

13 years ago
Created attachment 191855 [details]
newest minimal testcase

i got rid of the innermost nested tables, consolidated most of the <br> tags,
and cleaned up the code a bit.	the critical components to reproduce appear to
be the following:

1) the difference in font-weight between a:link and a:bover
2) the image, without height or width modifiers
3) sufficient contents of the inner table for it to reach a height of 600 px
4) a <br> below the inner table, within the outer one.

removing the valign="top" shows that the table isn't just gaining blank lines
at the bottom, since whitespace is added to both the top of the table (shifting
the image and link downward) and the bottom.

the behaviour ceases and the tables snap back to correct height apparently when
the bottom of the page extends beyond the bottom of the screen, at least in the
minimal testcase.
(Reporter)

Updated

13 years ago
Attachment #191402 - Attachment is obsolete: true
Attachment #191852 - Attachment is obsolete: true
I can reproduce the bug with several of the attached testcases using
SeaMonkey 2006120701 (pre reflow branch) on Linux.
SeaMonkey 2006120801 (post reflow branch) on Linux works fine though.
Looks like bug 300030 fixed this.
Weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(Hovering over links in first testcase results in webpage growing in height, as observed by the scrollbar)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(Hovering over links in first testcase results in webpage height not growing)

Concur with comment 15

-->RESOLVED FIXED 
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Depends on: 300030
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.