Fallback font-family is used when font-weight is not matched

RESOLVED WONTFIX

Status

Core Graveyard
GFX: Win32
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: Rod Whiteley, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When a style specifies bold together with a font family that does not support
bold, the specified font family is not used.  Instead, a fallback font family is
used.

The CSS 2.1 font matching algorithm
http://www.w3.org/TR/CSS21/fonts.html#algorithm says matching of
"3.font-weight...will never fail".

In the case of a family with only one weight, all weights should be assigned the
same face.  Therefore the family can be used at any weight.

Reproducible: Always

Steps to Reproduce:
1. In a web page, make an element's style specify a font family that does not
support bold, but specify font-weight: bold;
2. View the web page.
Actual Results:  
The specified font family is not used.  Default font family is used, with bold
weight.

Expected Results:  
Use the specified font family with normal weight.

On my system, some fonts that do not support bold are:  Lucida Sans Unicode,
BlippoLight, Viner Hand ITC.

Comment 1

12 years ago
Related to bug 249746?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to bug 249746?

Yes.  Bug 249746 says several things:

 - Bold should not cause fallback.  That part is the same as this bug.

 - Italic should not cause fallback.  CSS *wants* italic to cause fallback.

 - System-generated fonts should be used.  That would be nice, but it's a
separate issue.

 - At one time this worked.  I suspect this is true, because I noticed it when
updating a web page that I made using an earlier version of Firefox, and I do
not think I would have specified a font that did not work at that time.
Assignee: nobody → win32
Component: Layout: Fonts and Text → GFX: Win32
QA Contact: layout.fonts-and-text → ian
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.