Some links on AtomFilms.com are not clickable.

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: cpeterso, Assigned: joki (gone))

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    2000022820

Some links in AtomFilms.com's "Now Showing" page, such as the movie titles, are 
not clickable using Mozilla M14.

Reproducible: Always
Steps to Reproduce:
1. Go to AtomFilms.com
2. On the "Now Showing" page, try to click on the the film titles on the 
(white) right-hand side of the screen.


Actual Results:  Under IE5, the underlined film titles are links to other 
pages. Under Mozilla M14, these links do nothing. The mouse arrow does not even 
turn into a pointing hand.

Expected Results:  These links should be clickable.

Comment 1

19 years ago
Reassigning to joki
Assignee: troy → joki
The problem is on the page http://www.atomfilms.com/channels/daily.asp

The reason that the layout is wrong on this page is that the page detect for NS 
and then use document.layers

However the problem with the unclickable links is due to something else. 
Mozilla dosn't seem to be able to calculate which frame the mouse is over. This 
is very obvious if you try to select text. Therefor mozilla dosn't detect that 
the mouse is over the links in the center of the page (the yellow on white 
background)

Comment 3

19 years ago
I saved the page to disk, took out all javascript and stylesheets, and still go
the same problem.  So it's not the document.layers that's causing the problems.
The problem is that there are two frames overlapping each other. One in z-
index:1; and one in z-index:2;

This makes it impossible to select parts of the overlapped frame or click links 
within it.

attaching simplified testcase.
Whiteboard: [TESTCASE]

Comment 6

19 years ago
why hasn't this been marked as new yet?!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Moveing to testcase keyword
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 8

18 years ago
I was able to click on both the links in the simplified test case and go to 
mozilla.org in the latest Win32 build.  Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Fixed in the May 30th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.