Closed Bug 303598 Opened 15 years ago Closed 13 years ago

Software update fails if NtfsDisable8dot3NameCreation set to 1

Categories

(Toolkit :: Application Update, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mozillabugs, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050805 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050805 Firefox/1.0+

Software Update silently fails if
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem set
NtfsDisable8dot3NameCreation is set to 1.

Reproducible: Always

Steps to Reproduce:
1. Set HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem set
NtfsDisable8dot3NameCreation to 1
2. Reboot
3. Remove C:\Program Files\Deer Park Alpha 2
4. Do a clean install
5. Run Update
6. It informs you there's a new nightly available.
7. Click "Download & Install now" ... the file properly downloads as expected
8. After download is complete, a restart dialoge appears, click "Restart Deer
Park Now"
Actual Results:  
Deer Park closes... NOTHING HAPPENS!  No update, no error messages, nothing. 
Manually restarting Deer Park leaves you with your original build.

Expected Results:  
The updater should launch and update Deer Park.

Having NtfsDisable8dot3NameCreation set to 1 leads to other problems too (Bug
296916) so I'm going to file a seperate bug that this one will depend on.

Info on the regkey:
http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/Windows/2000/server/reskit/en-us/regentry/28231.asp

Run "dir /x" in C:\Program Files to see if an 8dot3 notation exists for a folder.
Depends on: 303599
How common is it to turn this on?  Should this block Firefox 1.5?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.5?
I don't know how common, but FOUR people in this thread had this problem:
http://forums.mozillazine.org/viewtopic.php?t=290721
It is often listed as a performance tweak on many Windows Performance sites.  My
guess is that quite a few geeks have this tweak in place.

See also Bug 296916.
Ditto here - it's a common tweak for NTFS (between that and disable last access
time).  Glad someone figured out what was causing it this problem.
Version: unspecified → Trunk
*** Bug 303416 has been marked as a duplicate of this bug. ***
Removing request to block 1.5 since the 1.5flags are not being used anymore and
requesting to block 1.8b4.
Flags: blocking-aviary1.5? → blocking1.8b4?
maybe for a future release but this isn't going to make 1.5
Flags: blocking1.9a1?
Flags: blocking1.8b4?
Flags: blocking1.8b4-
Flags: blocking1.8.1?
Was this bug fixed by bug 303599? I could have sworn it was.
OK, I just installed the 12/03/2006 2.0.0.1pre build from the Mozilla FTP site on a system with no trace of Firefox on it previously. I created a new profile and did an update check. As expected, it notified me that the 12/04/2006 nightly was available.  I clicked Download & Install Now and was notified that it downloaded and was verified.  Upon restarting Bon Echo and was greeted by the "Updating" dialog.  Furthermore, Help...About confirms that indeed I'm updated to the 12/04/2006 nightly.

So yes, I'd say it's fixed.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Please forgive me for being anal, but this should be resolved as WFM unless you're willing to verify that bug 303599 did, in fact, fix this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Fine
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Flags: blocking1.9a1?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.