Middle- and CTRL-clicks on links open new tab in background despite of preference

VERIFIED FIXED in Firefox1.5

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Ger Teunis, Assigned: Aaron Leventhal)

Tracking

({regression})

Trunk
Firefox1.5
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050806 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050806 Firefox/1.0+

When middle-cliking or CTRL-left-clicking a link the newly opened tab is created
and loaded in the background despite of the "Select new tab opened from links"
pref in options. This regressed in the last couple of days: I will try between
what build.

Reproducible: Always

Steps to Reproduce:
1. Browse to a page containing links
2. Make sure you enabled "Select new tab opened from links" in your options
3. Middle, CTRL-click or rightclick-link->Open Link in new tab

Actual Results:  
A new tab is created and loaded, but isn't selected.

Expected Results:  
A new tab is created and loaded and should be selected.

When single-window-mode is enabled (force links that open new windows to open in
a new tab) will open the tab correctly.
See bug 249136 comment 62.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Blocks: 249136
Assignee: nobody → aaronleventhal
No longer blocks: 249136
Depends on: 249136
Keywords: regression
Target Milestone: --- → Firefox1.1
Created attachment 191803 [details] [diff] [review]
patch

This fixes it for me.
(Assignee)

Comment 3

12 years ago
I just checked it in that fix because that was obviously a mistake and there is
no sense waiting until Monday.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

12 years ago
Thanks all, that was quick!
I noticed that new tabs firstly are created in the background now and after a
brief period (0.5 seconds) it gets selected. It is loosing a bit of snappynes now.

This is new in the recent releases, should I file a new bug on this or should I
mention it in bug 249136 ?
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> Thanks all, that was quick!
> I noticed that new tabs firstly are created in the background now and after a
> brief period (0.5 seconds) it gets selected. It is loosing a bit of snappynes now.
The bug 249136 shouldn't affect new blank tabs, like those created Ctrl+T. Are
you talking about those, or new tabs with content loading in them?

File a separate bug on the issue, please. Perhaps in a later release we can take
the risk of making changes to nsPresShell to fix bug 249136 in a less hacky way
(not using the "0" milisecond timeout, which makes it wait until other tab
creation work is done before focusing the new tab). The correct fix would be to
make the events able to propagate even when the new tab is focused but it wasn't
quite ready to be focused yet. Or have focus heal itself somehow once the tab
really is ready. That kind of fix wouldn't have cause the slight delay.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> The bug 249136 shouldn't affect new blank tabs, like those created Ctrl+T. Are
> you talking about those, or new tabs with content loading in them?

Only new tabs with content loading in them are unselected at first.
I've filed bug 303715 for it.
Thank you for your reply.
You need to log in before you can comment on or make changes to this bug.