bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

absolute position onXUL <deck> element causes browser crash

RESOLVED DUPLICATE of bug 137216

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 137216
13 years ago
13 years ago

People

(Reporter: Mark Porter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

this code demonstrates the bug:

<?xml version="1.0"?>
<window id="encounters_inner" title="encounters"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

		<deck style="position:absolute" selectedIndex="0">
		</deck>
</window>

Reproducible: Always

Steps to Reproduce:
1. attempt to load the xul file via local or remote url


Actual Results:  
Browser crash....get the firefox feedback dialogg and the XP app crashed
feedback dialog

Expected Results:  
Not sure here...is position absolute a valid css property for XUL elements?
certainly it deosn't make sence for a <deck> element (I did this on accident). 

Definitly shouldn't crash the browser. Silently ignored makes more sence.

I don't know where to get that info, sorry.
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 137216 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.