should be easier to turn off fdlibm

RESOLVED DUPLICATE of bug 291003

Status

()

RESOLVED DUPLICATE of bug 291003
13 years ago
13 years ago

People

(Reporter: mi+mozilla, Unassigned)

Tracking

Trunk
All
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.4; FreeBSD; X11; amd64) KHTML/3.4.1 (like Gecko)
Build Identifier: 

Modern OSes provide all the functionality offered by fdlibm. In fact, FreeBSD's 
-lm was derived from the same sources (from Sun). 
 
It may be desirable to complement (or replace) the Operating System's libm on 
some backwards systems, but turning the build of fdlibm off should be easy as 
turning on JS_READLINE, for example. 
 
I tried building js-1.5rc6a on FreeBSD/amd64 and FreeBSD/i386 and all ecma* and 
js1_* tests passed fine. 
 
I'm quite sure, it would work just fine on Linux and, probably, on Solaris too.  
 
Amazingly, despite fdlibm providing all the needed functions, js-1.5rc6a links 
with the system -lm too... 
 
Either one or the other -- preferably the native -lm, if possible, because it 
is more likely to be better optimized for the platform at hand by the OS or the 
compiler vendor (Compaq's ccc for Linux/alpha, Intel's icc for Linux, FreeBSD, 
and Windows i386, Sun's Forte for Sun/x86 and Sun/sparc). 

Reproducible: Always

Comment 1

13 years ago
Bug 291003 covers the same territory and can be used to accomplish the same results.

*** This bug has been marked as a duplicate of 291003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.